summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-14 21:34:36 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-14 21:35:03 +0100
commita265e29932ee47bab1c0d56181f72b098ea645ba (patch)
tree8a95bea1dc33ce797dd936cdb68d7f23f3671f86 /app-laptop
parentapp-laptop/thinkfan: Drop 0.9.3 (diff)
downloadgentoo-a265e29932ee47bab1c0d56181f72b098ea645ba.tar.gz
gentoo-a265e29932ee47bab1c0d56181f72b098ea645ba.tar.bz2
gentoo-a265e29932ee47bab1c0d56181f72b098ea645ba.zip
app-laptop/thinkfan: Use cmake.eclass
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkfan/thinkfan-1.0.2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-laptop/thinkfan/thinkfan-1.0.2.ebuild b/app-laptop/thinkfan/thinkfan-1.0.2.ebuild
index 59f5d7fce4b9..e08e6101e57b 100644
--- a/app-laptop/thinkfan/thinkfan-1.0.2.ebuild
+++ b/app-laptop/thinkfan/thinkfan-1.0.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils readme.gentoo-r1
+inherit cmake readme.gentoo-r1
DESCRIPTION="simple fan control program for thinkpads"
HOMEPAGE="http://thinkfan.sourceforge.net"
@@ -25,18 +25,18 @@ DOC_CONTENTS="
"
src_configure() {
- local mycmakeargs+=(
+ local mycmakeargs=(
-DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
-DUSE_NVML="$(usex nvidia)"
-DUSE_ATASMART="$(usex atasmart)"
-DUSE_YAML="$(usex yaml)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
readme.gentoo_create_doc
}