summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2016-07-07 19:13:23 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-08-11 10:07:58 +0200
commita10be51d3cce8abc3c5b7644e4d6d07f4af4f3dc (patch)
tree3564372854e84ba148accad9ecb9d4ad2f6fd92c /app-leechcraft/lc-bittorrent
parentapp-laptop/pommed: remove unused patches (diff)
downloadgentoo-a10be51d3cce8abc3c5b7644e4d6d07f4af4f3dc.tar.gz
gentoo-a10be51d3cce8abc3c5b7644e4d6d07f4af4f3dc.tar.bz2
gentoo-a10be51d3cce8abc3c5b7644e4d6d07f4af4f3dc.zip
app-leechcraft/lc-bittorrent: remove unused patches
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-leechcraft/lc-bittorrent')
-rw-r--r--app-leechcraft/lc-bittorrent/files/boost-1.50.patch38
-rw-r--r--app-leechcraft/lc-bittorrent/files/boost-1.52.patch14
2 files changed, 0 insertions, 52 deletions
diff --git a/app-leechcraft/lc-bittorrent/files/boost-1.50.patch b/app-leechcraft/lc-bittorrent/files/boost-1.50.patch
deleted file mode 100644
index 2abb31998082..000000000000
--- a/app-leechcraft/lc-bittorrent/files/boost-1.50.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/src/plugins/bittorrent/CMakeLists.txt b/src/plugins/bittorrent/CMakeLists.txt
-index de8a2f9..45d26da 100644
---- a/src/plugins/bittorrent/CMakeLists.txt
-+++ b/src/plugins/bittorrent/CMakeLists.txt
-@@ -153,7 +153,6 @@ IF (WIN32)
- ENDIF (WIN32)
- #ADD_DEFINITIONS(-DBOOST_DYN_LINK)
- ADD_DEFINITIONS(-DTORRENT_LINKING_SHARED)
--ADD_DEFINITIONS(-DBOOST_FILESYSTEM_VERSION=2) #workaround for building with boost 1.46
- #ADD_DEFINITIONS(-D_DLL)
- IF (NOT LC_NO_MOC)
- QT4_WRAP_CPP (MOC_SRCS ${HEADERS})
-diff --git a/src/plugins/bittorrent/torrentmaker.cpp b/src/plugins/bittorrent/torrentmaker.cpp
-index 313a6a5..467c4d8 100644
---- a/src/plugins/bittorrent/torrentmaker.cpp
-+++ b/src/plugins/bittorrent/torrentmaker.cpp
-@@ -40,7 +40,11 @@ namespace LeechCraft
- {
- bool FileFilter (const boost::filesystem::path& filename)
- {
-+#if BOOST_FILESYSTEM_VERSION == 2
- if (filename.leaf () [0] == '.')
-+#else
-+ if (filename.leaf ().string () [0] == '.')
-+#endif
- return false;
- QFileInfo fi (QString::fromUtf8 (filename.string ().c_str ()));
- if ((fi.isDir () ||
-@@ -74,7 +78,9 @@ namespace LeechCraft
- return;
- }
-
-+#if BOOST_FILESYSTEM_VERSION == 2
- boost::filesystem::path::default_name_check (boost::filesystem::no_check);
-+#endif
-
- libtorrent::file_storage fs;
- #if LIBTORRENT_VERSION_NUM >= 1600
diff --git a/app-leechcraft/lc-bittorrent/files/boost-1.52.patch b/app-leechcraft/lc-bittorrent/files/boost-1.52.patch
deleted file mode 100644
index bb5208ab0be5..000000000000
--- a/app-leechcraft/lc-bittorrent/files/boost-1.52.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/plugins/bittorrent/torrentplugin.cpp b/src/plugins/bittorrent/torrentplugin.cpp
-index b41f0f2..c20f847 100644
---- a/src/plugins/bittorrent/torrentplugin.cpp
-+++ b/src/plugins/bittorrent/torrentplugin.cpp
-@@ -31,6 +31,9 @@
- #include <QToolBar>
- #include <QHeaderView>
- #include <QInputDialog>
-+#include <boost/preprocessor/seq/size.hpp>
-+#include <boost/preprocessor/seq/elem.hpp>
-+#include <boost/preprocessor/repetition/repeat.hpp>
- #include <libtorrent/session.hpp>
- #include <libtorrent/version.hpp>
- #include <interfaces/entitytesthandleresult.h>