summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2017-02-25 19:49:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-26 12:58:56 +0100
commit09222bd0523d448c79f1434b042f55e440097adf (patch)
tree899893b57e6ed056d7eb0f4350388ccbedbc6b90 /app-leechcraft/lc-core
parentprofiles/arch/hppa: Mask USE=libsecret for dev-vcs/git. (diff)
downloadgentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.gz
gentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.bz2
gentoo-09222bd0523d448c79f1434b042f55e440097adf.zip
app-leechcraft: use Qt5, modernize the eclass and ebuilds
Closes: https://github.com/gentoo/gentoo/pull/4079
Diffstat (limited to 'app-leechcraft/lc-core')
-rw-r--r--app-leechcraft/lc-core/lc-core-9999.ebuild36
-rw-r--r--app-leechcraft/lc-core/metadata.xml10
2 files changed, 27 insertions, 19 deletions
diff --git a/app-leechcraft/lc-core/lc-core-9999.ebuild b/app-leechcraft/lc-core/lc-core-9999.ebuild
index a89da19a8782..41d7d4926e78 100644
--- a/app-leechcraft/lc-core/lc-core-9999.ebuild
+++ b/app-leechcraft/lc-core/lc-core-9999.ebuild
@@ -2,12 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
-EGIT_PROJECT="leechcraft-${PV}"
-inherit eutils leechcraft
+inherit eutils confutils leechcraft
DESCRIPTION="Core of LeechCraft, the modular network client"
@@ -15,20 +14,25 @@ SLOT="0"
KEYWORDS=""
IUSE="debug doc +sqlite postgres +qwt"
-COMMON_DEPEND=">=dev-libs/boost-1.46
- dev-qt/qtcore:4
- dev-qt/qtdbus:4
- dev-qt/qtdeclarative:4
- dev-qt/qtgui:4
- dev-qt/qtscript:4
- dev-qt/qtsql:4[postgres?,sqlite?]
- dev-qt/qtwebkit:4
- dev-qt/qtdbus:4
- qwt? ( x11-libs/qwt:6 )"
+COMMON_DEPEND=">=dev-libs/boost-1.62
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtscript:5
+ dev-qt/qtsql:5[postgres?,sqlite?]
+ dev-qt/qtdbus:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtconcurrent:5
+ dev-qt/linguist-tools:5
+ qwt? ( x11-libs/qwt:6[qt5] )"
DEPEND="${COMMON_DEPEND}
doc? ( app-doc/doxygen )"
RDEPEND="${COMMON_DEPEND}
- dev-qt/qtsvg:4
+ dev-qt/qtsvg:5
|| (
kde-frameworks/oxygen-icons
x11-themes/kfaenza
@@ -39,8 +43,8 @@ REQUIRED_USE="|| ( postgres sqlite )"
src_configure() {
local mycmakeargs=(
-DWITH_PLUGINS=False
- $(cmake-utils_use_with doc DOCS)
- $(cmake-utils_use_with qwt QWT)
+ -DWITH_DOCS=$(usex doc)
+ -DWITH_QWT=$(usex qwt)
)
if [[ ${PV} != 9999 ]]; then
mycmakeargs+=( -DLEECHCRAFT_VERSION=${PV} )
diff --git a/app-leechcraft/lc-core/metadata.xml b/app-leechcraft/lc-core/metadata.xml
index 93047c9afa13..79bb4d800dab 100644
--- a/app-leechcraft/lc-core/metadata.xml
+++ b/app-leechcraft/lc-core/metadata.xml
@@ -1,11 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>0xd34df00d@gmail.com</email>
+ <name>Georg Rudoy</name>
+ </maintainer>
<maintainer type="project">
- <email>leechcraft@gentoo.org</email>
- <name>LeechCraft</name>
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
</maintainer>
- <longdescription>Core of LeechCraft, the opensource modular network client providing a full-featured web browser, BitTorrent client and much more.</longdescription>
+ <longdescription>Core of LeechCraft, the opensource modular network client providing a full-featured web browser, BitTorrent client and much more.</longdescription>
<use>
<flag name="qwt">Support for QML plotting item through <pkg>x11-libs/qwt</pkg></flag>
</use>