summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2017-02-25 19:49:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-26 12:58:56 +0100
commit09222bd0523d448c79f1434b042f55e440097adf (patch)
tree899893b57e6ed056d7eb0f4350388ccbedbc6b90 /app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild
parentprofiles/arch/hppa: Mask USE=libsecret for dev-vcs/git. (diff)
downloadgentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.gz
gentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.bz2
gentoo-09222bd0523d448c79f1434b042f55e440097adf.zip
app-leechcraft: use Qt5, modernize the eclass and ebuilds
Closes: https://github.com/gentoo/gentoo/pull/4079
Diffstat (limited to 'app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild')
-rw-r--r--app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild26
1 files changed, 10 insertions, 16 deletions
diff --git a/app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild b/app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild
index 22a1f7df1e85..5cd11d589750 100644
--- a/app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild
+++ b/app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=6
inherit leechcraft
@@ -10,21 +10,15 @@ DESCRIPTION="UPower-based power manager for LeechCraft"
SLOT="0"
KEYWORDS=""
-IUSE="debug systemd"
+IUSE="debug"
DEPEND="~app-leechcraft/lc-core-${PV}
x11-libs/qwt:6
- dev-qt/qtdbus:4
- virtual/leechcraft-trayarea"
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtdbus:5
+ dev-qt/qtconcurrent:5
+"
RDEPEND="${DEPEND}
- !systemd? ( || ( >=sys-power/upower-0.99 sys-power/upower-pm-utils ) )
- systemd? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
-
-pkg_postinst() {
- if has_version '>=sys-power/upower-0.99'; then
- ewarn "The new sys-power/upower version you have installed doesn't have hibernate"
- ewarn "and suspend. If you need hibernate and suspend in ${PN}, and you use"
- ewarn "systemd, you should downgrade sys-power/upower to 0.9.23 series. All others"
- ewarn "should switch to sys-power/upower-pm-utils, also to 0.9.23 series."
- fi
-}
+ ~virtual/leechcraft-trayarea-${PV}
+ || ( sys-power/upower sys-power/upower-pm-utils )"