summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2017-02-25 19:49:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-26 12:58:56 +0100
commit09222bd0523d448c79f1434b042f55e440097adf (patch)
tree899893b57e6ed056d7eb0f4350388ccbedbc6b90 /app-leechcraft/lc-lmp
parentprofiles/arch/hppa: Mask USE=libsecret for dev-vcs/git. (diff)
downloadgentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.gz
gentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.bz2
gentoo-09222bd0523d448c79f1434b042f55e440097adf.zip
app-leechcraft: use Qt5, modernize the eclass and ebuilds
Closes: https://github.com/gentoo/gentoo/pull/4079
Diffstat (limited to 'app-leechcraft/lc-lmp')
-rw-r--r--app-leechcraft/lc-lmp/lc-lmp-9999.ebuild45
-rw-r--r--app-leechcraft/lc-lmp/metadata.xml24
2 files changed, 39 insertions, 30 deletions
diff --git a/app-leechcraft/lc-lmp/lc-lmp-9999.ebuild b/app-leechcraft/lc-lmp/lc-lmp-9999.ebuild
index c2891fa8e25a..84ec922b1f66 100644
--- a/app-leechcraft/lc-lmp/lc-lmp-9999.ebuild
+++ b/app-leechcraft/lc-lmp/lc-lmp-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=6
inherit leechcraft
@@ -14,27 +14,32 @@ IUSE="debug +fradj +graffiti +guess +mpris +mtp +mp3tunes potorchu"
# depend on gstreamer:0.10 to match current Qt deps
DEPEND="~app-leechcraft/lc-core-${PV}
- graffiti? ( media-libs/flac )
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtxml:5
+ media-libs/gstreamer:1.0
+
+ mpris? ( dev-qt/qtdbus:5 )
guess? ( app-i18n/libguess )
- media-libs/gstreamer:0.10
media-libs/taglib
- mpris? ( dev-qt/qtdbus:4 )
- mtp? (
- ~app-leechcraft/lc-devmon-${PV}
- media-libs/libmtp
- )
- potorchu? ( media-libs/libprojectm )
- dev-qt/qtdeclarative:4"
-RDEPEND="${DEPEND}"
+ mtp? ( media-libs/libmtp )
+ potorchu? ( media-libs/libprojectm )"
+RDEPEND="${DEPEND}
+ mtp? ( ~app-leechcraft/lc-devmon-${PV} )
+ graffiti? ( media-libs/flac )"
src_configure() {
- local mycmakeargs="
- $(cmake-utils_use_enable fradj LMP_FRADJ)
- $(cmake-utils_use_enable graffiti LMP_GRAFFITI)
- $(cmake-utils_use_enable guess LMP_LIBGUESS)
- $(cmake-utils_use_enable mpris LMP_MPRIS)
- $(cmake-utils_use_enable mtp LMP_MTPSYNC)
- $(cmake-utils_use_enable mp3tunes LMP_MP3TUNES)
- $(cmake-utils_use_enable potorchu LMP_POTORCHU)"
+ local mycmakeargs=(
+ -DENABLE_LMP_FRADJ=$(usex fradj)
+ -DENABLE_LMP_GRAFFITI=$(usex graffiti)
+ -DENABLE_LMP_LIBGUESS=$(usex guess)
+ -DENABLE_LMP_MPRIS=$(usex mpris)
+ -DENABLE_LMP_MTPSYNC=$(usex mtp)
+ -DENABLE_LMP_MP3TUNES=$(usex mp3tunes)
+ -DENABLE_LMP_POTORCHU=$(usex potorchu)
+ )
cmake-utils_src_configure
}
diff --git a/app-leechcraft/lc-lmp/metadata.xml b/app-leechcraft/lc-lmp/metadata.xml
index c6abcd9f6dba..87c916e3cb83 100644
--- a/app-leechcraft/lc-lmp/metadata.xml
+++ b/app-leechcraft/lc-lmp/metadata.xml
@@ -1,16 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>0xd34df00d@gmail.com</email>
+ <name>Georg Rudoy</name>
+ </maintainer>
<maintainer type="project">
- <email>leechcraft@gentoo.org</email>
- <name>LeechCraft</name>
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
</maintainer>
-<use>
- <flag name="fradj">Build FrAdj, the equalizer effect module</flag>
- <flag name="graffiti">Build media tags editor plugin</flag>
- <flag name="guess">Enable tags encoding guessing via the libguess library</flag>
- <flag name="mpris">Enable MPRIS support</flag>
- <flag name="mp3tunes">Build plugin for supporting the mp3tunes.com music locker service</flag>
- <flag name="potorchu"> Enable the projectM-based visualization effects module for LMP</flag>
-</use>
+ <use>
+ <flag name="fradj">Build FrAdj, the equalizer effect module</flag>
+ <flag name="graffiti">Build media tags editor plugin</flag>
+ <flag name="guess">Enable tags encoding guessing via the libguess library</flag>
+ <flag name="mpris">Enable MPRIS support</flag>
+ <flag name="mp3tunes">Build plugin for supporting the mp3tunes.com music locker service</flag>
+ <flag name="potorchu"> Enable the projectM-based visualization effects module for LMP</flag>
+ </use>
</pkgmetadata>