summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-01-10 16:05:01 -0600
committerWilliam Hubbs <williamh@gentoo.org>2019-01-10 16:06:20 -0600
commitf9d7aa4ddb50ad0a34454a5d14646340731e2102 (patch)
tree572bc63aa0c11da0540a128f73db6a875489631e /app-metrics/process-exporter/process-exporter-0.4.0.ebuild
parentmedia-gfx/geeqie: gtk3 is default in master branch (diff)
downloadgentoo-f9d7aa4ddb50ad0a34454a5d14646340731e2102.tar.gz
gentoo-f9d7aa4ddb50ad0a34454a5d14646340731e2102.tar.bz2
gentoo-f9d7aa4ddb50ad0a34454a5d14646340731e2102.zip
app-metrics/process-exporter: mine /proc to report process stats for prometheus
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-metrics/process-exporter/process-exporter-0.4.0.ebuild')
-rw-r--r--app-metrics/process-exporter/process-exporter-0.4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-metrics/process-exporter/process-exporter-0.4.0.ebuild b/app-metrics/process-exporter/process-exporter-0.4.0.ebuild
new file mode 100644
index 000000000000..4ea9b6f62fa9
--- /dev/null
+++ b/app-metrics/process-exporter/process-exporter-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/ncabatoff/process-exporter
+
+inherit golang-build golang-vcs-snapshot systemd
+
+DESCRIPTION="Process exporter for prometheus"
+HOMEPAGE="https://github.com/ncabatoff/process-exporter"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+
+src_compile() {
+ pushd "src/${EGO_PN}" || die
+ GOPATH="${S}" emake build
+}
+
+src_install() {
+ pushd "src/${EGO_PN}" || die
+ dobin ${PN}
+dodoc *.md
+ insinto /etc/${PN}
+ doins packaging/conf/all.yaml
+ systemd_dounit packaging/${PN}.service
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}