summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-08-19 16:17:36 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-08-19 16:17:36 +0200
commit5c506bc6696dc86ad4b3fbade2e577595c538642 (patch)
tree828a36b5a7698d97935301bad48c51f019dc6a38 /app-metrics
parentdev-libs/jsoncpp: Fix building docs (diff)
downloadgentoo-5c506bc6696dc86ad4b3fbade2e577595c538642.tar.gz
gentoo-5c506bc6696dc86ad4b3fbade2e577595c538642.tar.bz2
gentoo-5c506bc6696dc86ad4b3fbade2e577595c538642.zip
app-metrics/prometheus: Version bump to 2.12.0
Package-Manager: Portage-2.3.72, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus/Manifest1
-rw-r--r--app-metrics/prometheus/prometheus-2.12.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index 72ff75916a78..4ed98f772621 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -1,2 +1,3 @@
DIST prometheus-2.11.2.tar.gz 12132678 BLAKE2B 0b6b9a93b7329c124f901d0acc6130132aa187142f0416e087c12f20b0cd35f8564a27d0df8c0bc811284b9811f446344adf700d6611afac3c5c1131c208b341 SHA512 cecdaf4522885bdf62492667d92475a97c54b04c1e93f48b6078def319fe33f5e28aafbab61e3609413615d6f853e817564fc372e5d1df0d867fe9fa333f6de9
+DIST prometheus-2.12.0.tar.gz 15221347 BLAKE2B 6061562e6bafe8e2373ad676e7acd2b5d5ff8e195cf4c1abd709347992c16970b64b225e9f58f33a801ff521abc78422281d97d8c5307a80a64fb8c8a8d8d5fe SHA512 3d3b5ce3afd13714a8fa96964784fa40feb650459f657cbc695c6a7e866f89c488132b408d78ea101804532768c51c3913607bf001f27d3f05c3df9efe3cab82
DIST prometheus-2.9.2.tar.gz 11477683 BLAKE2B f0c18c57ff0fe292710174a91080a84ecf0375b4335aacaf4a8e32c842a9346b9fd48888ef8a19a597511c57eb8af7f90cca57d0cc51b9de4558c3f22953d165 SHA512 4cce1827580e49b1659ad492de946a81694c1dab90e079f3f0e56c1991254cf4ecac7f052aac75bf58a0b95d3cf4daa8c15b3e8305a3c089570da40c44a8ccc0
diff --git a/app-metrics/prometheus/prometheus-2.12.0.ebuild b/app-metrics/prometheus/prometheus-2.12.0.ebuild
new file mode 100644
index 000000000000..5a036cba4edc
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.12.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=v${PV/_rc/-rc.}
+PROMETHEUS_COMMIT="43acd0e"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="https://${EGO_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/go-1.12
+ >=dev-util/promu-0.3.0"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GO111MODULE=on GOPATH="${S}" GOCACHE="${T}/go-cache" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}