summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-31 14:20:08 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-31 14:20:08 +0200
commitfab5eef76374e27acdf1aca851f5b7f336000159 (patch)
tree1c044fe77c266ec288e9143c0c6f76d96ecfbb40 /app-misc/acdctl/acdctl-1.1-r2.ebuild
parentapp-misc/rlwrap: drop 0.42-r1, 0.43 (diff)
downloadgentoo-fab5eef76374e27acdf1aca851f5b7f336000159.tar.gz
gentoo-fab5eef76374e27acdf1aca851f5b7f336000159.tar.bz2
gentoo-fab5eef76374e27acdf1aca851f5b7f336000159.zip
app-misc/acdctl: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/722400 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/acdctl/acdctl-1.1-r2.ebuild')
-rw-r--r--app-misc/acdctl/acdctl-1.1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/acdctl/acdctl-1.1-r2.ebuild b/app-misc/acdctl/acdctl-1.1-r2.ebuild
new file mode 100644
index 000000000000..df2784238b54
--- /dev/null
+++ b/app-misc/acdctl/acdctl-1.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Apple Cinema Display Control"
+HOMEPAGE="https://web.archive.org/web/20090725222711/http://technocage.com:80/~caskey/acdctl/"
+SRC_URI="http://www.technocage.com/~caskey/acdctl/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc"
+
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-warnings.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin acdctl
+ einstalldocs
+}