summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-09 22:45:56 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-09 22:47:07 +0200
commit8b16cfe63fe5f9eb3869a61b8ce27d8882da35ec (patch)
treebe4bdf5b7befa29fb3077dfe9888d061d513acbc /app-misc/color
parentapp-misc/beanstalkd: Remove old, bug 605728 (diff)
downloadgentoo-8b16cfe63fe5f9eb3869a61b8ce27d8882da35ec.tar.gz
gentoo-8b16cfe63fe5f9eb3869a61b8ce27d8882da35ec.tar.bz2
gentoo-8b16cfe63fe5f9eb3869a61b8ce27d8882da35ec.zip
app-misc/color: EAPI bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-misc/color')
-rw-r--r--app-misc/color/color-1.2-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/color/color-1.2-r2.ebuild b/app-misc/color/color-1.2-r2.ebuild
new file mode 100644
index 000000000000..e14fb8433a05
--- /dev/null
+++ b/app-misc/color/color-1.2-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Easily add ANSI colouring to shell scripts"
+HOMEPAGE="http://www.runslinux.net/?page_id=10"
+SRC_URI="http://runslinux.net/projects/color/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PV}-ldflags.patch
+ default
+ tc-export CC
+}
+
+src_install() {
+ dobin color
+ dodoc CHANGELOG README
+
+ # symlink for british users.
+ dosym color /usr/bin/colour
+}
+
+pkg_postinst() {
+ elog "For information on using colour in your shell scripts,"
+ elog "run \`color\` without any arguments."
+ elog
+ elog "To see all the colours available, use this command"
+ elog " $ color --list"
+ elog
+ elog "More examples are available in ${EPREFIX}/usr/share/doc/${PF}."
+}