summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-03-10 15:10:56 +0100
committerAmy Liffey <amynka@gentoo.org>2017-03-16 15:33:45 +0100
commit3a752b9a08b0a3db157c85100a1a23e4c4d895d1 (patch)
tree3be6d217e3d18f22231dc875ea3dbc9a917d533a /app-misc/elasticsearch/elasticsearch-5.2.2.ebuild
parentprofiles: unmask boost[mpi] (diff)
downloadgentoo-3a752b9a08b0a3db157c85100a1a23e4c4d895d1.tar.gz
gentoo-3a752b9a08b0a3db157c85100a1a23e4c4d895d1.tar.bz2
gentoo-3a752b9a08b0a3db157c85100a1a23e4c4d895d1.zip
app-misc/elasticsearch: bump to 5.2.2
Closes: #4195 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-misc/elasticsearch/elasticsearch-5.2.2.ebuild')
-rw-r--r--app-misc/elasticsearch/elasticsearch-5.2.2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/app-misc/elasticsearch/elasticsearch-5.2.2.ebuild b/app-misc/elasticsearch/elasticsearch-5.2.2.ebuild
new file mode 100644
index 000000000000..ba141a646d4f
--- /dev/null
+++ b/app-misc/elasticsearch/elasticsearch-5.2.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils systemd user
+
+DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
+HOMEPAGE="https://www.elastic.co/products/elasticsearch"
+SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+
+RDEPEND="virtual/jre:1.8"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 /bin/bash /usr/share/${PN} ${PN}
+}
+
+src_prepare() {
+ rm -rf bin/*.{bat,exe} || die
+ rm LICENSE.txt || die
+
+ default
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /etc/${PN}/scripts
+
+ insinto /etc/${PN}
+ doins config/*
+ rm -rf config || die
+
+ insinto /usr/share/${PN}
+ doins -r ./*
+
+ exeinto /usr/share/${PN}/bin
+ doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
+
+ chmod +x "${D}"/usr/share/${PN}/bin/* || die
+
+ keepdir /var/{lib,log}/${PN}
+ keepdir /usr/share/${PN}/plugins
+
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d" "${PN}.conf"
+
+ insinto /etc/sysctl.d
+ newins "${FILESDIR}/${PN}.sysctl.d" "${PN}.conf"
+
+ newinitd "${FILESDIR}/${PN}.init8" "${PN}"
+ newconfd "${FILESDIR}/${PN}.conf3" "${PN}"
+ systemd_newunit "${FILESDIR}"/${PN}.service6 "${PN}.service"
+}
+
+pkg_postinst() {
+ elog
+ elog "You may create multiple instances of ${PN} by"
+ elog "symlinking the init script:"
+ elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
+ elog
+ elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
+ elog "from /etc/elasticsearch into the configuration directory of the instance:"
+ elog "/etc/${PN}/instance"
+ elog
+}