summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-05-22 13:34:07 +0000
committerThomas Deutschmann <whissi@gentoo.org>2020-06-12 16:32:23 +0200
commitf715c87aa4d77849fb2abf05225b7bcad98a740a (patch)
tree6604ad3b9f0a2f98053de7942602680f2fd5007d /app-misc/elasticsearch
parentdev-db/redis: drop old (diff)
downloadgentoo-f715c87aa4d77849fb2abf05225b7bcad98a740a.tar.gz
gentoo-f715c87aa4d77849fb2abf05225b7bcad98a740a.tar.bz2
gentoo-f715c87aa4d77849fb2abf05225b7bcad98a740a.zip
app-misc/elasticsearch: bump to 7.7.0
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-misc/elasticsearch')
-rw-r--r--app-misc/elasticsearch/Manifest2
-rw-r--r--app-misc/elasticsearch/elasticsearch-7.7.0.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/app-misc/elasticsearch/Manifest b/app-misc/elasticsearch/Manifest
index 99c33de25e39..cfe38f90da53 100644
--- a/app-misc/elasticsearch/Manifest
+++ b/app-misc/elasticsearch/Manifest
@@ -1,5 +1,7 @@
DIST elasticsearch-5.6.16.tar.gz 33894983 BLAKE2B f96e78f1f28d8106948c91a0d31ea3d41b538fb0fd8534e2f52be651cf22986c76eae67c58c8ef10fef218d1646b1b4b5aa0a3625520e62e482063420775e92e SHA512 cc831e50ce311366484c47cf9fead9bd6562035132e6fd29508e78776dd71846c713d8d1e7a0a99338df46cad124149fb5d767e0ae0bbbed0b50153e234f2631
DIST elasticsearch-6.8.8.tar.gz 149927766 BLAKE2B 329bb778100125d9624acc84252fe8281cd4ee3823fbafeabf8aeeca529c3cd8902b197d5e5a852d55f7a56ec410312e3932b34736607890dedad9e12c3afe2e SHA512 c703d6230a42b77fb0f169158afbc18517118375e341ef889c231acc0f096a44716ba4fc1a2558fd000b0ceff4d9c3aff2f2c792f2c2ae92f0e7f82c6a70eaec
DIST elasticsearch-7.6.2-no-jdk-linux-x86_64.tar.gz 148140124 BLAKE2B 9a850011533052d7a4041484936dfa2c8fe7f7976314147bc2b1d5f239bbdfe68a3593d3e0d2bb4d709a71e81aa7c200f9530921dab9d50c0ab3e349f4769ffb SHA512 aa5f499b26e92e19a673093fe2ff73c1c03a8da029b59cb83db43f9e2dfd7c650ee6a122bcf647b7e83f658ad9b9cc64092e6e7c1b4f8476f2973a6006b8df3c
+DIST elasticsearch-7.7.0-no-jdk-linux-x86_64.tar.gz 157716656 BLAKE2B 812c4db511f844fb23cb79bdfe3778281f1b6dad6a45553380829e330231304ce0e18eb975867e8474f652a63bdab2f4fb8c14158753aa8b29db5debfd3f00ae SHA512 a8d6cb7186301f50ba72ee5cde6c26390bdb6a8c13d902a75c63038b3dbb3cd7e544bbf6934d88324d722a213b7bf2efc0b27f9cae64428e6842d640bda5ee54
DIST elasticsearch-oss-6.8.8.tar.gz 68655829 BLAKE2B 808b9dd49f7d9c9968e6e1c5dcd8d1150d3638b8380ad0608f1e85f00d98c6da6d0c9c324f244b510d35ecec0f37b40e29fd0761b83118e137cf394c231cc0e8 SHA512 7c5972d365a8a2a80c351039ff54a274bb1f95379d6f4feab4fa01360541bffa58409ffac6030acade24be54d1cc57e7ea24a7cf29531aba35a565718e30288d
DIST elasticsearch-oss-7.6.2-no-jdk-linux-x86_64.tar.gz 72570377 BLAKE2B 5a5ec3e79cba236dd4a6ffd279b0fca4ad882c877b418261b0314d8101885a2d2496c837b44e5dbefe5ed994aeeca488a8f08a2ba26c4b44b156c180dae6004c SHA512 6197a0b62f577cd0692c1fb97a473a9971f8fef383dc6ef618035785dbc662947d2adbc425ce130ef531cbfaf9add9ed5da5a698387e770c49af820644d67e72
+DIST elasticsearch-oss-7.7.0-no-jdk-linux-x86_64.tar.gz 73216528 BLAKE2B f0f1a3d3347ea37703e90bd896b24f6e3c58406d9fb20f3607a4d08eee325b5ae293db48d1afdc208468ee775b9085a28f39f2e175b67e4881bfb61d5cb85a9a SHA512 f9b323cff078a0dc856f99efd164775a9cd0718bb0ddb6c4d4817fa53cae71748f1aec5158afa45d4b29076043cbada9743a996e685439436e93d94a9eff2768
diff --git a/app-misc/elasticsearch/elasticsearch-7.7.0.ebuild b/app-misc/elasticsearch/elasticsearch-7.7.0.ebuild
new file mode 100644
index 000000000000..2155270debec
--- /dev/null
+++ b/app-misc/elasticsearch/elasticsearch-7.7.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
+HOMEPAGE="https://www.elastic.co/products/elasticsearch"
+SRC_URI="x-pack? ( https://artifacts.elastic.co/downloads/${PN}/${P}-no-jdk-linux-x86_64.tar.gz )
+ !x-pack? ( https://artifacts.elastic.co/downloads/${PN}/${PN}-oss-${PV}-no-jdk-linux-x86_64.tar.gz )"
+LICENSE="Apache-2.0 BSD-2 LGPL-3 MIT public-domain x-pack? ( Elastic )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="x-pack"
+
+RDEPEND="acct-group/elasticsearch
+ acct-user/elasticsearch
+ virtual/jre"
+
+QA_PRESTRIPPED="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
+
+src_prepare() {
+ default
+
+ rm LICENSE.txt NOTICE.txt || die
+ rmdir logs || die
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /etc/${PN}/scripts
+
+ insinto /etc/${PN}
+ doins -r config/.
+ rm -r config || die
+
+ fowners root:${PN} /etc/${PN}
+ fperms 2750 /etc/${PN}
+
+ insinto /usr/share/${PN}
+ doins -r .
+
+ exeinto /usr/share/${PN}/bin
+ doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
+
+ chmod +x "${ED}"/usr/share/${PN}/bin/* || die
+
+ if use x-pack; then
+ chmod +x "${ED}"/usr/share/${PN}/modules/x-pack-ml/platform/linux-x86_64/bin/* || die
+ fi
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ fperms 0750 /var/{lib,log}/${PN}
+ dodir /usr/share/${PN}/plugins
+
+ insinto /etc/sysctl.d
+ newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
+
+ newconfd "${FILESDIR}/${PN}.conf.3" ${PN}
+ newinitd "${FILESDIR}/${PN}.init.7" ${PN}
+
+ systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d" ${PN}.conf
+ systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
+}
+
+pkg_postinst() {
+ elog
+ elog "You may create multiple instances of ${PN} by"
+ elog "symlinking the init script:"
+ elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
+ elog
+ elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
+ elog "from /etc/${PN} into the configuration directory of the instance:"
+ elog "/etc/${PN}/instance"
+ elog
+ ewarn "Please make sure you have proper permissions on /etc/${PN}"
+ ewarn "prior to keystore generation or you may experience startup fails."
+ ewarn "chown root:${PN} /etc/${PN} && chmod 2750 /etc/${PN}"
+ ewarn "chown root:${PN} /etc/${PN}/${PN}.keystore && chmod 0660 /etc/${PN}/${PN}.keystore"
+}