summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2019-07-22 01:50:24 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-22 05:24:59 +0200
commita322e604f61c4c5579b0c6241748816570cf7068 (patch)
treeaa74fb44133d38447b9950ad2e45e1f5884720e0 /app-misc/g810-led
parentdev-java/icedtea-bin: arm64 stable (bug #685480) (diff)
downloadgentoo-a322e604f61c4c5579b0c6241748816570cf7068.tar.gz
gentoo-a322e604f61c4c5579b0c6241748816570cf7068.tar.bz2
gentoo-a322e604f61c4c5579b0c6241748816570cf7068.zip
app-misc/g810-led: Version bump, 0.3.6
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-misc/g810-led')
-rw-r--r--app-misc/g810-led/Manifest1
-rw-r--r--app-misc/g810-led/g810-led-0.3.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/g810-led/Manifest b/app-misc/g810-led/Manifest
index 66452dd12a2d..ed64b952a54a 100644
--- a/app-misc/g810-led/Manifest
+++ b/app-misc/g810-led/Manifest
@@ -1 +1,2 @@
DIST g810-led-0.3.5.tar.gz 34543 BLAKE2B 6f5a946beea269d684bccaab5102f53b638f5ef66557809e50783fc0ce0ec508f2c8486b1da59347d4fb7099d4fee06bf364cafee2fe74fee88cce7860638a8e SHA512 25ed0a65b6c08de19a86c460a78a4b5a06e6e70e312840f7940317d71a3fbea723ce0926500258afbd4bccc534117228b2e800a54388bb70e00431bf8ae1668c
+DIST g810-led-0.3.6.tar.gz 34544 BLAKE2B 142fd54d7721a1deebfb019b644a4c8ab0fd5e1662391075cea67a4c7b7145034101f14c22975bdf079ee5b8e56c4a73e18fe31ce5d7fcf20ff4b9c64ee85502 SHA512 5a1877ee135a662bc5eb15c1afe5370cfe9243b4479823e3492f0da8f407b1438e3d7e35bd9992eea8dcbd4d548c9acdb7e74f4c99efbd4e9e8e6ddae33f8a5b
diff --git a/app-misc/g810-led/g810-led-0.3.6.ebuild b/app-misc/g810-led/g810-led-0.3.6.ebuild
new file mode 100644
index 000000000000..2e51fcb5d4f2
--- /dev/null
+++ b/app-misc/g810-led/g810-led-0.3.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd udev eutils
+
+DESCRIPTION="Led controller for Logitech G- Keyboards"
+HOMEPAGE="https://github.com/MatMoul/g810-led"
+SRC_URI="https://github.com/MatMoul/g810-led/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+hidapi"
+
+RDEPEND="
+ hidapi? ( dev-libs/hidapi:= )
+ !hidapi? ( virtual/libusb:= )
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=("README.md" "sample_profiles" "sample_effects")
+
+src_compile() {
+ emake LIB="$(usex hidapi hidapi libusb)"
+}
+
+src_install() {
+ dolib.so "lib/libg810-led.so.${PV}"
+ dosym "libg810-led.so.${PV}" "/usr/$(get_libdir)/libg810-led.so"
+
+ dobin bin/g810-led
+ local boards=(213 410 413 512 513 610 910 pro)
+ local x
+ for x in "${boards[@]}"; do
+ dosym g810-led "/usr/bin/g${x}-led"
+ done
+
+ systemd_dounit systemd/g810-led.service
+ systemd_dounit systemd/g810-led-reboot.service
+
+ udev_newrules udev/g810-led.rules 60-g810-led.rules
+
+ einstalldocs
+}