summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/geoclue/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/geoclue/files')
-rw-r--r--app-misc/geoclue/files/geoclue-0.12.0_p20110307-use-fallback-mac.patch16
-rw-r--r--app-misc/geoclue/files/geoclue-0.12.0_p20110307-use-flag.patch79
-rw-r--r--app-misc/geoclue/files/geoclue-0.12.99-gpsd.patch73
3 files changed, 168 insertions, 0 deletions
diff --git a/app-misc/geoclue/files/geoclue-0.12.0_p20110307-use-fallback-mac.patch b/app-misc/geoclue/files/geoclue-0.12.0_p20110307-use-fallback-mac.patch
new file mode 100644
index 000000000000..9c9115a284ef
--- /dev/null
+++ b/app-misc/geoclue/files/geoclue-0.12.0_p20110307-use-fallback-mac.patch
@@ -0,0 +1,16 @@
+Force geoclue to use the "fallback" mac address fetching code.
+The NM-based code does not seem to work.
+
+Patch by Kevin McCarthy <signals@gentoo.org>
+
+--- src/connectivity.c
++++ src/connectivity.c
+@@ -218,7 +218,7 @@
+ geoclue_connectivity_get_router_mac (GeoclueConnectivity *self)
+ {
+ if (self == NULL ||
+- GEOCLUE_CONNECTIVITY_GET_INTERFACE (self)->get_router_mac == NULL) {
++ GEOCLUE_CONNECTIVITY_GET_INTERFACE (self)->get_router_mac == NULL || 1) {
+ char *mac = NULL;
+ guint i;
+ int ret_val;
diff --git a/app-misc/geoclue/files/geoclue-0.12.0_p20110307-use-flag.patch b/app-misc/geoclue/files/geoclue-0.12.0_p20110307-use-flag.patch
new file mode 100644
index 000000000000..236c98928ba7
--- /dev/null
+++ b/app-misc/geoclue/files/geoclue-0.12.0_p20110307-use-flag.patch
@@ -0,0 +1,79 @@
+Add configure options for all providers except localnet.
+
+Patch by Kevin McCarthy <signals@gentoo.org>
+
+--- configure.ac
++++ configure.ac
+@@ -158,7 +158,71 @@
+ AC_SUBST(CONNECTIVITY_LIBS)
+ AC_SUBST(CONNECTIVITY_CFLAGS)
+
+-PROVIDER_SUBDIRS="example hostip geonames nominatim manual plazes localnet yahoo gsmloc"
++PROVIDER_SUBDIRS="localnet"
++
++AC_ARG_ENABLE(hostip,
++ AS_HELP_STRING([--enable-hostip=@<:@no/yes/auto@:>@],
++ [build with hostip support]), ,
++ enable_hostip=auto)
++
++if test "x$enable_hostip" != "xno"; then
++ PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS hostip"
++fi
++
++AC_ARG_ENABLE(geonames,
++ AS_HELP_STRING([--enable-geonames=@<:@no/yes/auto@:>@],
++ [build with geonames support]), ,
++ enable_geonames=auto)
++
++if test "x$enable_geonames" != "xno"; then
++ PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS geonames"
++fi
++
++AC_ARG_ENABLE(nominatim,
++ AS_HELP_STRING([--enable-nominatim=@<:@no/yes/auto@:>@],
++ [build with nominatim support]), ,
++ enable_nominatim=auto)
++
++if test "x$enable_nominatim" != "xno"; then
++ PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS nominatim"
++fi
++
++AC_ARG_ENABLE(manual,
++ AS_HELP_STRING([--enable-manual=@<:@no/yes/auto@:>@],
++ [build with manual support]), ,
++ enable_manual=auto)
++
++if test "x$enable_manual" != "xno"; then
++ PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS manual"
++fi
++
++AC_ARG_ENABLE(plazes,
++ AS_HELP_STRING([--enable-plazes=@<:@no/yes/auto@:>@],
++ [build with plazes support]), ,
++ enable_plazes=auto)
++
++if test "x$enable_plazes" != "xno"; then
++ PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS plazes"
++fi
++
++AC_ARG_ENABLE(yahoo,
++ AS_HELP_STRING([--enable-yahoo=@<:@no/yes/auto@:>@],
++ [build with yahoo support]), ,
++ enable_yahoo=auto)
++
++if test "x$enable_yahoo" != "xno"; then
++ PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS yahoo"
++fi
++
++AC_ARG_ENABLE(gsmloc,
++ AS_HELP_STRING([--enable-gsmloc=@<:@no/yes/auto@:>@],
++ [build with gsmloc support]), ,
++ enable_gsmloc=auto)
++
++if test "x$enable_gsmloc" != "xno"; then
++ PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS gsmloc"
++fi
++
+
+ # -----------------------------------------------------------
+ # gypsy / gpsd / skyhook
diff --git a/app-misc/geoclue/files/geoclue-0.12.99-gpsd.patch b/app-misc/geoclue/files/geoclue-0.12.99-gpsd.patch
new file mode 100644
index 000000000000..51160d6296e0
--- /dev/null
+++ b/app-misc/geoclue/files/geoclue-0.12.99-gpsd.patch
@@ -0,0 +1,73 @@
+Description: Refactoring to support new libgps API
+Author: James Page <james.page@ubuntu.com>
+Bug: https://bugs.freedesktop.org/show_bug.cgi?id=40996
+Forwarded: no
+
+--- providers/gpsd/geoclue-gpsd.c
++++ providers/gpsd/geoclue-gpsd.c
+@@ -40,7 +40,12 @@
+ #include <geoclue/gc-iface-position.h>
+ #include <geoclue/gc-iface-velocity.h>
+
++#if GPSD_API_MAJOR_VERSION >= 5
++/* gps_data conflicts with gps_data function */
++typedef struct gps_data_t gps_data_l;
++#else
+ typedef struct gps_data_t gps_data;
++#endif
+ typedef struct gps_fix_t gps_fix;
+
+ /* only listing used tags */
+@@ -59,7 +64,11 @@
+ char *host;
+ char *port;
+
++#if GPSD_API_MAJOR_VERSION >= 5
++ gps_data_l *gpsdata;
++#else
+ gps_data *gpsdata;
++#endif
+
+ gps_fix *last_fix;
+
+@@ -394,10 +403,16 @@
+ static gboolean
+ geoclue_gpsd_start_gpsd (GeoclueGpsd *self)
+ {
++#if GPSD_API_MAJOR_VERSION >= 5
++ int status = gps_open (self->host, self->port, self->gpsdata);
++ if (status == 0) {
++ gps_stream(self->gpsdata, WATCH_ENABLE | WATCH_NMEA, NULL);
++#else
+ self->gpsdata = gps_open (self->host, self->port);
+ if (self->gpsdata) {
+ gps_stream(self->gpsdata, WATCH_ENABLE | WATCH_NMEA | POLL_NONBLOCK, NULL);
+ gps_set_raw_hook (self->gpsdata, gpsd_raw_hook);
++#endif
+ return TRUE;
+ } else {
+ g_warning ("gps_open() failed, is gpsd running (host=%s,port=%s)?", self->host, self->port);
+@@ -410,10 +425,23 @@
+ {
+ GeoclueGpsd *self = (GeoclueGpsd*)data;
+ if (self->gpsdata) {
++#if GPSD_API_MAJOR_VERSION >= 5
++ /* gps_poll and gps_set_raw_hook no longer present in this API version */
++ if (gps_waiting(self->gpsdata, 500)) {
++ if (gps_read(self->gpsdata) == -1) {
++ geoclue_gpsd_set_status (self, GEOCLUE_STATUS_ERROR);
++ geoclue_gpsd_stop_gpsd(self);
++ return FALSE;
++ } else {
++ /* Call existing raw_hook to process the data */
++ gpsd_raw_hook(self->gpsdata, NULL, 0);
++ }
++#else
+ if (gps_poll(self->gpsdata) < 0) {
+ geoclue_gpsd_set_status (self, GEOCLUE_STATUS_ERROR);
+ geoclue_gpsd_stop_gpsd(self);
+ return FALSE;
++#endif
+ }
+ }
+ return TRUE;