summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-25 18:57:12 +0100
committerSam James <sam@gentoo.org>2021-02-26 14:25:53 +0000
commita2a81415b3fdf44680a83011727f8937c239fec7 (patch)
tree86704df225bf8cd97b17abd1d9e9039c78c2a0a1 /app-misc/goobook
parentapp-admin/ansible-lint: Bump to 5.0.2 (diff)
downloadgentoo-a2a81415b3fdf44680a83011727f8937c239fec7.tar.gz
gentoo-a2a81415b3fdf44680a83011727f8937c239fec7.tar.bz2
gentoo-a2a81415b3fdf44680a83011727f8937c239fec7.zip
app-misc/goobook: Bump to 3.5.1
Closes: https://bugs.gentoo.org/746308 Bug: https://bugs.gentoo.org/718974 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/goobook')
-rw-r--r--app-misc/goobook/Manifest1
-rw-r--r--app-misc/goobook/goobook-3.5.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/goobook/Manifest b/app-misc/goobook/Manifest
index 77ff4c3178c0..1ce6d6f2f81a 100644
--- a/app-misc/goobook/Manifest
+++ b/app-misc/goobook/Manifest
@@ -1 +1,2 @@
DIST goobook-3.4.tar.gz 35100 BLAKE2B 8419f79313a68b108f08a0f7a0b6809d01979a01044d011f53acdf554e87f20f3ac41819a4823abd74e1c8ce0350956e91f17ae9a9342551a263af72b7b6c98a SHA512 e58cdee28ee4464548b04800740d0ffd40ce972efd52af9509f3de603eed9e50fad03cc9116f1d0dc42f77621bbab58d73bff98cf35a3cb55b24a0f04b26cd4d
+DIST goobook-3.5.1.tar.gz 38176 BLAKE2B 99a068256ca83e800a2d2e82c88adba85797107dc72edde9fbb3c9790ef38fff627b4db64c21baff14aa8a4c69788c29aeb01dae60533c7f389352aee9401e9c SHA512 58d056d7d76843bc874e55424912bb00068541e674b780511b7753da31f2df9514baa188017dd0a7479b5527cd50c47e35f37afc493bdc973e0eb1624998a611
diff --git a/app-misc/goobook/goobook-3.5.1.ebuild b/app-misc/goobook/goobook-3.5.1.ebuild
new file mode 100644
index 000000000000..be5d2164e594
--- /dev/null
+++ b/app-misc/goobook/goobook-3.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Access your Google contacts from the command line"
+HOMEPAGE="https://gitlab.com/goobook/goobook"
+SRC_URI="mirror://pypi/g/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/google-api-python-client-1.7.12[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-1.5.0[${PYTHON_USEDEP}]
+ <dev-python/oauth2client-5[${PYTHON_USEDEP}]"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="
+To setup initial authentication, execute:
+
+~ $ goobook authenticate
+
+If you want to use goobook from mutt, add this in your .muttrc file:
+ set query_command=\"goobook query '%s'\"
+to query address book.
+
+You may find more information and advanced configuration tips at
+https://pypi.org/project/${PN}/${PV} in \"Configure/Mutt\" section"
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}