summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-08 08:25:47 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-08 08:25:47 +0200
commite5dd966c420938f1cf5c3533fdf9ac75c98b3e64 (patch)
treec95e4f21f30b8170c3c97bef216cd9970f920f2b /app-misc/graphlcd-base
parentgames-emulation/dolphin: [QA] slot op on net-libs/mbedtls (diff)
downloadgentoo-e5dd966c420938f1cf5c3533fdf9ac75c98b3e64.tar.gz
gentoo-e5dd966c420938f1cf5c3533fdf9ac75c98b3e64.tar.bz2
gentoo-e5dd966c420938f1cf5c3533fdf9ac75c98b3e64.zip
app-misc/graphlcd-base: Use pkg-config instead of freetype-config.
Closes: https://bugs.gentoo.org/654902 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'app-misc/graphlcd-base')
-rw-r--r--app-misc/graphlcd-base/files/graphlcd-base-0.1.9-freetype_pkgconfig.patch30
-rw-r--r--app-misc/graphlcd-base/graphlcd-base-0.1.9.ebuild20
2 files changed, 43 insertions, 7 deletions
diff --git a/app-misc/graphlcd-base/files/graphlcd-base-0.1.9-freetype_pkgconfig.patch b/app-misc/graphlcd-base/files/graphlcd-base-0.1.9-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..cbdaf1ceb59a
--- /dev/null
+++ b/app-misc/graphlcd-base/files/graphlcd-base-0.1.9-freetype_pkgconfig.patch
@@ -0,0 +1,30 @@
+--- graphlcd-base-0.1.9/glcdgraphics/Makefile
++++ graphlcd-base-0.1.9/glcdgraphics/Makefile
+@@ -33,9 +33,9 @@
+ -include $(DEPFILE)
+
+ ifdef HAVE_FREETYPE2
+- ifneq ($(shell which freetype-config),)
+- INCLUDES += $(shell freetype-config --cflags)
+- LIBS += $(shell freetype-config --libs)
++ ifneq ($(shell which pkg-config),)
++ INCLUDES += $(shell pkg-config --cflags freetype2)
++ LIBS += $(shell pkg-config --libs freetype2)
+ else
+ INCLUDES += -I/usr/include/freetype -I/usr/local/include/freetype
+ LIBS += -lfreetype
+--- graphlcd-base-0.1.9/tools/genfont/Makefile
++++ graphlcd-base-0.1.9/tools/genfont/Makefile
+@@ -9,10 +9,10 @@
+ OBJS = genfont.o
+
+ INCLUDES += -I../../
+-INCLUDES += `freetype-config --cflags`
++INCLUDES += `pkg-config --cflags freetype2`
+
+ LIBDIRS += -L../../glcdgraphics/
+-LIBS += `freetype-config --libs`
++LIBS += `pkg-config --libs freetype2`
+
+ all: $(PRGNAME)
+ .PHONY: all
diff --git a/app-misc/graphlcd-base/graphlcd-base-0.1.9.ebuild b/app-misc/graphlcd-base/graphlcd-base-0.1.9.ebuild
index 8a5684039573..7c3f216d9771 100644
--- a/app-misc/graphlcd-base/graphlcd-base-0.1.9.ebuild
+++ b/app-misc/graphlcd-base/graphlcd-base-0.1.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,20 +16,26 @@ SLOT="0"
LICENSE="GPL-2"
IUSE="g15"
-DEPEND="media-libs/freetype"
-RDEPEND="g15? ( app-misc/g15daemon )
- media-libs/freetype"
+CDEPEND="media-libs/freetype"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ g15? ( app-misc/g15daemon )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.1.5-nostrip.patch"
+ "${FILESDIR}/${PN}-0.1.9-freetype_pkgconfig.patch"
+)
src_prepare() {
sed -i Make.config -e "s:usr\/local:usr:" -e "s:FLAGS *=:FLAGS ?=:"
- eapply "${FILESDIR}/${PN}-0.1.5-nostrip.patch"
+
+ default
sed -i glcdskin/Makefile -e "s:-shared:\$(LDFLAGS) -shared:"
#gcc-6 fix
sed -i glcddrivers/futabaMDM166A.c -e "s:0xff7f0004:(int) 0xff7f0004:"
-
- default
}
src_install() {