summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/jdictionary
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/jdictionary')
-rw-r--r--app-misc/jdictionary/Manifest1
-rw-r--r--app-misc/jdictionary/jdictionary-1.8-r2.ebuild40
-rw-r--r--app-misc/jdictionary/jdictionary-1.8-r3.ebuild44
-rw-r--r--app-misc/jdictionary/metadata.xml8
4 files changed, 93 insertions, 0 deletions
diff --git a/app-misc/jdictionary/Manifest b/app-misc/jdictionary/Manifest
new file mode 100644
index 000000000000..c5bc092a2244
--- /dev/null
+++ b/app-misc/jdictionary/Manifest
@@ -0,0 +1 @@
+DIST jdictionary-1_8.zip 467815 SHA256 0243ca1031e6bbdb3f12c10b7f2d267ce9a213e934af775aeb008e2e2a6db826 SHA512 87b46dbc1f8408a83bc8ec41aa842c6cb82519eb40cb09478f28dd7f18478e7e35214c66503b84facca94ddc208136a7747c9f0b5c5981d511ba90660aef7af2 WHIRLPOOL 48fa27857f0e1e9f480f523165d686da3861d1e614c0dd0016e0c3f2517e2d1586ad04fed94f1af96ff54b476e6350efae03a566a4089a27d49a6f8a8a663007
diff --git a/app-misc/jdictionary/jdictionary-1.8-r2.ebuild b/app-misc/jdictionary/jdictionary-1.8-r2.ebuild
new file mode 100644
index 000000000000..11166a40fb17
--- /dev/null
+++ b/app-misc/jdictionary/jdictionary-1.8-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2 eutils
+
+DESCRIPTION="A online Java-based dictionary"
+HOMEPAGE="http://jdictionary.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jdictionary/jdictionary-${PV/./_}.zip"
+
+IUSE=""
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND=">=virtual/jre-1.3"
+DEPEND=">=virtual/jdk-1.3
+ app-arch/unzip"
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mkdir compiled
+
+ jar xf ${PN}.jar || die "failed to unpack jar"
+ cp -r resources compiled
+}
+
+src_compile() {
+ ejavac -classpath . $(find . -name \*.java) -d compiled || die "failed to build"
+ jar cf ${PN}.jar -C compiled . || die "failed to make jar"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ java-pkg_dolauncher ${PN} --main info.jdictionary.JDictionary
+ make_desktop_entry ${PN} JDictionary
+}
diff --git a/app-misc/jdictionary/jdictionary-1.8-r3.ebuild b/app-misc/jdictionary/jdictionary-1.8-r3.ebuild
new file mode 100644
index 000000000000..3008a3199501
--- /dev/null
+++ b/app-misc/jdictionary/jdictionary-1.8-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2 eutils
+
+DESCRIPTION="A online Java-based dictionary"
+HOMEPAGE="http://jdictionary.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jdictionary/jdictionary-${PV/./_}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.5"
+DEPEND="
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+java_prepare() {
+ mkdir compiled || die
+ unpack ./${PN}.jar || die
+ cp -r resources compiled || die
+
+ find \( -name '*.jar' -o -name '*.class' \) -exec rm {} + || die
+}
+
+src_compile() {
+ ejavac -classpath . -encoding ISO-8859-1 $(find . -name \*.java) -d compiled || die
+ jar cf ${PN}.jar -C compiled . || die
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ java-pkg_dolauncher ${PN} --main info.jdictionary.JDictionary
+ make_desktop_entry ${PN} JDictionary
+}
diff --git a/app-misc/jdictionary/metadata.xml b/app-misc/jdictionary/metadata.xml
new file mode 100644
index 000000000000..2c92fc556776
--- /dev/null
+++ b/app-misc/jdictionary/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jdictionary</remote-id>
+ </upstream>
+</pkgmetadata>