summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-01 19:54:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 19:57:45 +0100
commitfcb863ac9e62fad4d197b0bc3ac01dedb2ff42c5 (patch)
tree62c97db077d604044df7e3fb5f64deb98a2a42eb /app-misc/jpipe
parentsys-apps/i2c-tools: Remove DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-fcb863ac9e62fad4d197b0bc3ac01dedb2ff42c5.tar.gz
gentoo-fcb863ac9e62fad4d197b0bc3ac01dedb2ff42c5.tar.bz2
gentoo-fcb863ac9e62fad4d197b0bc3ac01dedb2ff42c5.zip
app-misc/jpipe: Fix Python dependencies
DISTUTILS_USE_SETUPTOOLS is not used with DISTUTILS_OPTIONAL, the dep on setuptools needs to be declared explicitly. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-misc/jpipe')
-rw-r--r--app-misc/jpipe/jpipe-0.2.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-misc/jpipe/jpipe-0.2.0.ebuild b/app-misc/jpipe/jpipe-0.2.0.ebuild
index bbab903965e1..8988122f3364 100644
--- a/app-misc/jpipe/jpipe-0.2.0.ebuild
+++ b/app-misc/jpipe/jpipe-0.2.0.ebuild
@@ -1,10 +1,9 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
GO_OPTIONAL=1
DISTUTILS_OPTIONAL=1
-DISTUTILS_USE_SETUPTOOLS=bdepend
PYTHON_COMPAT=( python3_{7,8,9,10} )
inherit go-module distutils-r1
@@ -384,6 +383,10 @@ BDEPEND="
app-arch/unzip
>=dev-lang/go-1.12
)
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
"
RDEPEND="
jpp-symlink? ( !app-misc/jp[jpp(-)] )