summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/leave
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/leave')
-rw-r--r--app-misc/leave/Manifest1
-rw-r--r--app-misc/leave/files/README9
-rw-r--r--app-misc/leave/files/leave-fix-makefile.diff20
-rw-r--r--app-misc/leave/leave-20100918.ebuild34
-rw-r--r--app-misc/leave/metadata.xml5
5 files changed, 69 insertions, 0 deletions
diff --git a/app-misc/leave/Manifest b/app-misc/leave/Manifest
new file mode 100644
index 000000000000..09004f131995
--- /dev/null
+++ b/app-misc/leave/Manifest
@@ -0,0 +1 @@
+DIST leave-20100918.tar.gz 3477 SHA256 a467a4841b9d0a2daafbc5485d3761a9ca14b84f17320bc224b490edabfd0c97 SHA512 69df594800159bc80baeb3945aad144ceabe21bdac22ed2cd706b0ec610895dc82e58bae59ed0230eb97e909812bc90237b7c70e965125e7fa6767972a6259d1 WHIRLPOOL 8c7a0dd09916133cf6207e4540da63391c6310bf541d6461efd6b178754b6d8e268968fb5bf3dfb0c6bbacd23e1ce87b53f2a1d301e8b0535cb28013fa3fefdf
diff --git a/app-misc/leave/files/README b/app-misc/leave/files/README
new file mode 100644
index 000000000000..1af71d7431fd
--- /dev/null
+++ b/app-misc/leave/files/README
@@ -0,0 +1,9 @@
+The leave utility waits until the specified time, then reminds you that you
+have to leave. You are reminded 5 minutes and 1 minute before the actual
+time, at the time, and every minute thereafter. When you log off, leave
+exits just before it would have printed the next message.
+
+To get rid of leave you should either log off or use `kill -s KILL` giving its
+process id.
+
+This program is included with FreeBSD and is distributed under the BSD license.
diff --git a/app-misc/leave/files/leave-fix-makefile.diff b/app-misc/leave/files/leave-fix-makefile.diff
new file mode 100644
index 000000000000..efcb89eadea6
--- /dev/null
+++ b/app-misc/leave/files/leave-fix-makefile.diff
@@ -0,0 +1,20 @@
+--- Makefile.orig 2004-10-16 23:04:50.144563171 -0400
++++ Makefile 2004-10-16 23:57:27.639495962 -0400
+@@ -2,5 +2,16 @@
+ # $FreeBSD: /repoman/r/ncvs/src/usr.bin/leave/Makefile,v 1.5 2002/02/08 22:31:41 markm Exp $
+
+ PROG= leave
++CC ?= gcc
++CFLAGS=
++LDFLAGS=
+
+-.include <bsd.prog.mk>
++#.include <bsd.prog.mk>
++
++all: $(PROG)
++$(PROG): leave.o
++ $(CC) $(LDFLAGS) leave.o -o $(PROG)
++leave.o:
++ $(CC) $(CFLAGS) -c leave.c
++clean:
++ rm -f $(PROG) *.o
diff --git a/app-misc/leave/leave-20100918.ebuild b/app-misc/leave/leave-20100918.ebuild
new file mode 100644
index 000000000000..e2412fd36985
--- /dev/null
+++ b/app-misc/leave/leave-20100918.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Command-line tool from FreeBSD that reminds you when its time to leave"
+HOMEPAGE="http://www.freebsd.org/cgi/cvsweb.cgi/src/usr.bin/leave/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-fix-makefile.diff"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"\
+ || die "emake failed"
+}
+
+src_install() {
+ dobin leave || die "dobin failed"
+ doman leave.1 || die "doman failed"
+ dodoc "${FILESDIR}/README" || die "dodoc failed"
+}
diff --git a/app-misc/leave/metadata.xml b/app-misc/leave/metadata.xml
new file mode 100644
index 000000000000..40149c995561
--- /dev/null
+++ b/app-misc/leave/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>