summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-11-27 10:51:34 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-27 10:54:18 +0000
commitb34d1c9d5a0860fbfbbd78790e77dee2563317c4 (patch)
treef6c2b4635ba6c4e265eb961b669eaf092c52294e /app-misc/mc
parentnet-libs/gnutls-3.6.15: add compilation fix for macOS (diff)
downloadgentoo-b34d1c9d5a0860fbfbbd78790e77dee2563317c4.tar.gz
gentoo-b34d1c9d5a0860fbfbbd78790e77dee2563317c4.tar.bz2
gentoo-b34d1c9d5a0860fbfbbd78790e77dee2563317c4.zip
app-misc/mc: map Shift+F<N> keys to alacritty and tmux
Similar to xterm and screen these should just work. Currently 'mc' hardcodes terminal names to add a workaround. Ideally it should not. Meanwhile expand the list of affected terminals. Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/files/mc-4.8.25-alacritty-tmux.patch26
-rw-r--r--app-misc/mc/mc-4.8.25-r1.ebuild110
2 files changed, 136 insertions, 0 deletions
diff --git a/app-misc/mc/files/mc-4.8.25-alacritty-tmux.patch b/app-misc/mc/files/mc-4.8.25-alacritty-tmux.patch
new file mode 100644
index 000000000000..239ac5cb7cb2
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.25-alacritty-tmux.patch
@@ -0,0 +1,26 @@
+http://midnight-commander.org/ticket/4149
+--- a/misc/mc.lib
++++ b/misc/mc.lib
+@@ -116,6 +116,9 @@ alt-shift-left=\\e[1\;4D
+ alt-shift-up=\\e[1\;4A
+ alt-shift-down=\\e[1\;4B
+
++[terminal:alacritty]
++copy=xterm
++
+ [terminal:gnome]
+ copy=xterm
+
+@@ -137,6 +140,12 @@ copy=xterm
+ [terminal:screen-256color]
+ copy=xterm
+
++[terminal:tmux]
++copy=xterm
++
++[terminal:tmux-256color]
++copy=xterm
++
+ [terminal:ibmpc3]
+ f11=\\e[Y
+ f12=\\e[Z
diff --git a/app-misc/mc/mc-4.8.25-r1.ebuild b/app-misc/mc/mc-4.8.25-r1.ebuild
new file mode 100644
index 000000000000..636e8060c7d1
--- /dev/null
+++ b/app-misc/mc/mc-4.8.25-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+MY_P=${P/_/-}
+
+DESCRIPTION="GNU Midnight Commander is a text based file manager"
+HOMEPAGE="https://www.midnight-commander.org"
+SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+edit gpm nls samba sftp +slang spell test unicode X +xdg"
+
+REQUIRED_USE="spell? ( edit )"
+
+RDEPEND=">=dev-libs/glib-2.26.0:2
+ gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs )
+ samba? ( net-fs/samba )
+ sftp? ( net-libs/libssh2 )
+ slang? ( >=sys-libs/slang-2 )
+ !slang? ( sys-libs/ncurses:0=[unicode?] )
+ spell? ( app-text/aspell )
+ X? ( x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-libs/check )
+ "
+
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.8.25-alacritty-tmux.patch
+)
+
+pkg_pretend() {
+ if use slang && use unicode ; then
+ ewarn "\"unicode\" USE flag only takes effect when the \"slang\" USE flag is disabled."
+ fi
+}
+
+src_configure() {
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"
+
+ local myeconfargs=(
+ --enable-charset
+ --enable-vfs
+ --with-homedir=$(usex xdg 'XDG' '.mc')
+ --with-screen=$(usex slang 'slang' "ncurses$(usex unicode 'w' '')")
+ $(use_enable kernel_linux vfs-undelfs)
+ # Today mclib does not expose any headers and is linked to
+ # single 'mc' binary. Thus there is no advantage of having
+ # a library. Let's avoid shared library altogether
+ # as it also conflicts with sci-libs/mc: bug #685938
+ --disable-mclib
+ $(use_enable nls)
+ $(use_enable samba vfs-smb)
+ $(use_enable sftp vfs-sftp)
+ $(use_enable spell aspell)
+ $(use_enable test tests)
+ $(use_with gpm gpm-mouse)
+ $(use_with X x)
+ $(use_with edit internal-edit)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # CK_FORK=no to avoid using fork() in check library
+ # as mc mocks fork() itself: bug #644462.
+ #
+ # VERBOSE=1 to make test failures contain detailed
+ # information.
+ CK_FORK=no emake check VERBOSE=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README NEWS
+
+ # fix bug #334383
+ if use kernel_linux && [[ ${EUID} == 0 ]] ; then
+ fowners root:tty /usr/libexec/mc/cons.saver
+ fperms g+s /usr/libexec/mc/cons.saver
+ fi
+
+ if ! use xdg ; then
+ sed 's@MC_XDG_OPEN="xdg-open"@MC_XDG_OPEN="/bin/false"@' \
+ -i "${ED}"/usr/libexec/mc/ext.d/*.sh || die
+ fi
+}
+
+pkg_postinst() {
+ elog "To enable exiting to latest working directory,"
+ elog "put this into your ~/.bashrc:"
+ elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
+}