summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-30 14:37:01 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-30 14:37:01 +0200
commitcf834f85f7aea35df5db65803ca71af6c208667b (patch)
treed4e7441a002243cc9ca54854c7a88b30267bd42f /app-misc/mkcert/mkcert-1.0.1.ebuild
parentmedia-video/unifi-video: revbump for conf permission issue (diff)
downloadgentoo-cf834f85f7aea35df5db65803ca71af6c208667b.tar.gz
gentoo-cf834f85f7aea35df5db65803ca71af6c208667b.tar.bz2
gentoo-cf834f85f7aea35df5db65803ca71af6c208667b.zip
app-misc/mkcert: Initial version
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-misc/mkcert/mkcert-1.0.1.ebuild')
-rw-r--r--app-misc/mkcert/mkcert-1.0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/mkcert/mkcert-1.0.1.ebuild b/app-misc/mkcert/mkcert-1.0.1.ebuild
new file mode 100644
index 000000000000..0176c20c9259
--- /dev/null
+++ b/app-misc/mkcert/mkcert-1.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/FiloSottile/mkcert"
+
+inherit golang-build golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="A zero-config tool to make locally trusted development certificates"
+HOMEPAGE="https://github.com/FiloSottile/mkcert"
+SRC_URI="https://github.com/FiloSottile/mkcert/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go install -v ${EGO_PN} || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/mkcert
+ dodoc src/${EGO_PN}/README.md
+}