summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-17 22:08:01 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-17 22:10:26 -0700
commitb1777bbb3d5f288ce8185f06162f2747a6329403 (patch)
tree6ee480a726a94459d1c280a2807c2ee8c400fa1a /app-misc/mosquitto
parentdev-python/prompt_toolkit: Bump to 3.0.19 (diff)
downloadgentoo-b1777bbb3d5f288ce8185f06162f2747a6329403.tar.gz
gentoo-b1777bbb3d5f288ce8185f06162f2747a6329403.tar.bz2
gentoo-b1777bbb3d5f288ce8185f06162f2747a6329403.zip
app-misc/mosquitto: Add migration elog info
And provide mosquitto-copy.sh. Closes: https://bugs.gentoo.org/794070 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc/mosquitto')
-rw-r--r--app-misc/mosquitto/mosquitto-2.0.10.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/app-misc/mosquitto/mosquitto-2.0.10.ebuild b/app-misc/mosquitto/mosquitto-2.0.10.ebuild
index 9129a115a3e4..bfc38380fd1b 100644
--- a/app-misc/mosquitto/mosquitto-2.0.10.ebuild
+++ b/app-misc/mosquitto/mosquitto-2.0.10.ebuild
@@ -96,6 +96,8 @@ src_install() {
doinitd "${FILESDIR}"/mosquitto
insinto /etc/mosquitto
doins mosquitto.conf
+ insinto /usr/share/mosquitto
+ doins misc/letsencrypt/mosquitto-copy.sh
systemd_dounit "${FILESDIR}/mosquitto.service"
if use examples; then
@@ -103,3 +105,19 @@ src_install() {
dodoc -r examples
fi
}
+
+pkg_postinst() {
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 "$v") -lt 2 ]]; then
+ elog
+ elog "Please read the migration guide at:"
+ elog "https://mosquitto.org/documentation/migrating-to-2-0/"
+ elog
+ elog "If you use Lets Encrypt TLS certificates, take note of"
+ elog "the changes required to run the daemon as the unprivileged"
+ elog "mosquitto user. The mosquitto-copy.sh script has been"
+ elog "installed to /usr/share/mosquitto/ for your convenience."
+ elog
+ fi
+ done
+}