summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/mtail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/mtail')
-rw-r--r--app-misc/mtail/Manifest2
-rw-r--r--app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch52
-rw-r--r--app-misc/mtail/metadata.xml12
-rw-r--r--app-misc/mtail/mtail-1.1.1-r2.ebuild27
-rw-r--r--app-misc/mtail/mtail-1.1.1-r3.ebuild31
5 files changed, 124 insertions, 0 deletions
diff --git a/app-misc/mtail/Manifest b/app-misc/mtail/Manifest
new file mode 100644
index 000000000000..9e6efceede34
--- /dev/null
+++ b/app-misc/mtail/Manifest
@@ -0,0 +1,2 @@
+DIST mtail-1.1.1.tgz 9124 SHA256 1c82feb4ced3dc861497d4adc27a4d62d7002112bcfa24d1655348dda79bf3ab SHA512 987816ce5d12996192c881be1ac5a28c3457757e981ab35e657fb226c3980a22091c9fc85f68c13eb1c01939e08e492814b6a03c9b1f4f4bc1878c4f13ec8a0e WHIRLPOOL 2fbcbd3f3ab76dbbd801c898b8a9a32c636c02d69ddfcc505e280f7fcbb0aaa8e8f7f6c6f6fbdf05a753b460a086af573d25d5ba991ce3002d8047c9e69b5552
+DIST mtailrc-syslog.sample 1785 SHA256 3ec8e4fb26d138aab3e445d33adef5180db2a45eb65a942432c4c170840a3682 SHA512 d6bbaafa7c599f443c788697087ebef69a8e279b0715fa4e5b770531cbd254a646014fa98e5e5d444c48d23974201d36a856b34507a91e1b6abbb423f7015c75 WHIRLPOOL 40a6cf32c13aa86145570828e3cfbf2e6253ecdffc8103f86237286f170338e97aaf7087f6d3d25c6ffbbf3eb1afd1d41aa94a5266f8cd9181be756bbbe1b108
diff --git a/app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch b/app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch
new file mode 100644
index 000000000000..9645e263deda
--- /dev/null
+++ b/app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch
@@ -0,0 +1,52 @@
+--- mtail.orig 2003-11-07 19:02:34.000000000 +0000
++++ mtail 2003-11-07 19:19:18.000000000 +0000
+@@ -46,6 +46,7 @@
+ verbose = 0
+ silent = 0
+ active = 0
++remove_blanks = 0
+
+ # sets up the interrupt handler, calls processargs(), sets up and starts the
+ # tailers.
+@@ -119,6 +120,8 @@
+ if line[len(line)-1] == '\n':
+ line = line[:len(line)-1]
+ line = filter(line)
++ if remove_blanks and not line:
++ continue
+ lock.acquire()
+ try:
+ if (multiple or verbose) and (not silent) \
+@@ -138,12 +141,14 @@
+ global verbose
+ global silent
+ global config_file
++ global remove_blanks
+ filenames = []
+ lines = None
+ follow = 0
+ try:
+ opts, pargs = getopt.getopt(sys.argv[1:], 'fn:?hvq', ["follow",
+- "lines=", "help", "verbose", "quiet", "silent", "config="])
++ "lines=", "help", "verbose", "quiet", "silent", "config=",
++ "remove-blanks"])
+ except getopt.error:
+ print 'unrecognized option!'
+ print
+@@ -163,6 +168,8 @@
+ silent = 1
+ elif opt[0] in ['--config']:
+ config_file = opt[1]
++ elif opt[0] in ['--remove-blanks']:
++ remove_blanks = 1
+ if lines == None:
+ lines = 10
+ for filename in pargs:
+@@ -186,6 +193,7 @@
+ print ' -v, --verbose always output headers giving file names'
+ print ' -q, --quiet, --silent never output headers giving file names'
+ print ' --config=FILE use config file FILE instead of ~/.mtailrc'
++ print ' --remove-blanks do not display blank lines'
+ print
+ print 'with more than one filename, mtail will precede each chunk from'
+ print 'each with a header giving the file name. if no filenames are given'
diff --git a/app-misc/mtail/metadata.xml b/app-misc/mtail/metadata.xml
new file mode 100644
index 000000000000..36a21bace4d6
--- /dev/null
+++ b/app-misc/mtail/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <longdescription lang="en">
+ mtail is a small tail workalike that performs output coloring using
+ ansi escape sequences (although the sequences are overridable, so you
+ could cause it to output something else, e.g. html font tags, if you
+ really wanted to). mtail is written in python, is fairly small, and
+ should be relatively platform-independent.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-misc/mtail/mtail-1.1.1-r2.ebuild b/app-misc/mtail/mtail-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..b6fa941fb5ed
--- /dev/null
+++ b/app-misc/mtail/mtail-1.1.1-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils python
+
+DESCRIPTION="Tail workalike, that performs output colourising"
+HOMEPAGE="http://matt.immute.net/src/mtail/"
+SRC_URI="http://matt.immute.net/src/mtail/mtail-${PV}.tgz
+ http://matt.immute.net/src/mtail/mtailrc-syslog.sample"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="alpha amd64 ~mips ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-remove-blanks.patch
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ dobin mtail || die
+ dodoc CHANGES mtailrc.sample README "${DISTDIR}"/mtailrc-syslog.sample || die
+}
diff --git a/app-misc/mtail/mtail-1.1.1-r3.ebuild b/app-misc/mtail/mtail-1.1.1-r3.ebuild
new file mode 100644
index 000000000000..e39550b60f0d
--- /dev/null
+++ b/app-misc/mtail/mtail-1.1.1-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1
+
+DESCRIPTION="Tail workalike, that performs output colourising"
+HOMEPAGE="http://matt.immute.net/src/mtail/"
+SRC_URI="http://matt.immute.net/src/mtail/mtail-${PV}.tgz
+ http://matt.immute.net/src/mtail/mtailrc-syslog.sample"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND=${PYTHON_DEPS}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-remove-blanks.patch
+ python_fix_shebang .
+}
+
+src_install() {
+ dobin mtail || die
+ dodoc CHANGES mtailrc.sample README "${DISTDIR}"/mtailrc-syslog.sample || die
+}