summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-03-08 22:20:10 -0400
committerCraig Andrews <candrews@gentoo.org>2020-03-08 22:23:30 -0400
commit835f6f924b66ee9004cae17e0c5bd8a3b3161323 (patch)
tree6c886ffcb050f414044e149407ceacba411181cc /app-misc/neofetch/neofetch-7.0.0.ebuild
parentx11-apps/xinit: Fix postinstall message (diff)
downloadgentoo-835f6f924b66ee9004cae17e0c5bd8a3b3161323.tar.gz
gentoo-835f6f924b66ee9004cae17e0c5bd8a3b3161323.tar.bz2
gentoo-835f6f924b66ee9004cae17e0c5bd8a3b3161323.zip
app-misc/neofetch: 7.0.0 version bump
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'app-misc/neofetch/neofetch-7.0.0.ebuild')
-rw-r--r--app-misc/neofetch/neofetch-7.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/neofetch/neofetch-7.0.0.ebuild b/app-misc/neofetch/neofetch-7.0.0.ebuild
new file mode 100644
index 000000000000..16837479730e
--- /dev/null
+++ b/app-misc/neofetch/neofetch-7.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~mips ~ppc64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dylanaraps/neofetch.git"
+fi
+
+DESCRIPTION="Simple information system script"
+HOMEPAGE="https://github.com/dylanaraps/neofetch"
+LICENSE="MIT-with-advertising"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="sys-apps/pciutils
+ X? (
+ media-gfx/imagemagick
+ media-libs/imlib2
+ www-client/w3m[imlib]
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ )"