summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-09-04 17:10:08 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-09-04 17:10:08 -0500
commit6458db8c80e509b9ddd8efc9080ede40d6396846 (patch)
treeb47f524316205a9334fd8435fb78ff68d8d5b76b /app-misc/notary
parentdev-python/flexmock: Update HOMEPAGE (diff)
downloadgentoo-6458db8c80e509b9ddd8efc9080ede40d6396846.tar.gz
gentoo-6458db8c80e509b9ddd8efc9080ede40d6396846.tar.bz2
gentoo-6458db8c80e509b9ddd8efc9080ede40d6396846.zip
app-misc/notary: 0.7.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-misc/notary')
-rw-r--r--app-misc/notary/Manifest1
-rw-r--r--app-misc/notary/notary-0.7.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/notary/Manifest b/app-misc/notary/Manifest
index ef95fe07f703..93321a20bbdf 100644
--- a/app-misc/notary/Manifest
+++ b/app-misc/notary/Manifest
@@ -1 +1,2 @@
DIST notary-0.6.1.tar.gz 5741924 BLAKE2B 125e1e09178f090de9d73bb97170737d03c8f43927cf070a2c78e0c5eff3cd56a58aaf703a4ba60aa3e1bd7e22d2ceb0921abaa98e6f871ed1131249e44c622d SHA512 76e223c0c5c59796db924f0e52ea59d2bdbb101a9a059cd70d336928dcac616943d75fc9b8d7703de8609b2f694d2fc5627deb341971dc9401c00974261d57c3
+DIST notary-0.7.0.tar.gz 7146025 BLAKE2B 2aafa82e27eb498d21d09781b54f9a40df57ba23fd4386b5d8fdc0eb09a74b761a1bc3c618ad2403b21e049c4dfb9e75281e949cc8f29474da6903d5fc06ede3 SHA512 8996f4d64fda5db54d460ae8168360fdde86986752b30255ab9cf9cf12d475f88d7ac4f2b0e15d6cb9ee8eff2709306fd0b3d38708ee41caa94862d795ca6a75
diff --git a/app-misc/notary/notary-0.7.0.ebuild b/app-misc/notary/notary-0.7.0.ebuild
new file mode 100644
index 000000000000..141759da1bd1
--- /dev/null
+++ b/app-misc/notary/notary-0.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=b0b6bfdd
+
+DESCRIPTION="A project that allows anyone to have trust over arbitrary collections of data"
+HOMEPAGE="https://github.com/theupdateframework/notary"
+SRC_URI="https://github.com/theupdateframework/notary/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-group/notary
+ acct-user/notary
+"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ emake GITCOMMIT=${GIT_COMMIT} NOTARY_VERSION=${PV} binaries
+}
+
+src_install() {
+ dobin bin/${PN}{,-server,-signer}
+ insinto /var/lib/notary
+ doins -r migrations fixtures
+ fowners -R ${PN}:${PN} /var/lib/notary
+ fperms -R 0600 /var/lib/notary/fixtures/database/
+ newinitd "${FILESDIR}"/notary-signer.initd notary-signer
+ newconfd "${FILESDIR}"/notary-signer.confd notary-signer
+ newinitd "${FILESDIR}"/notary-server.initd notary-server
+ newconfd "${FILESDIR}"/notary-server.confd notary-server
+}