summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-11-18 15:29:55 -0700
committerTim Harder <radhermit@gentoo.org>2019-11-18 15:29:55 -0700
commit927d13562b65ccd464d2b31775a07ccdcfaf5c02 (patch)
tree871d8278856d0f912a84738d1e0db2f851c97512 /app-misc/ranger
parentapp-admin/gopass: drop myself as a maintainer (diff)
downloadgentoo-927d13562b65ccd464d2b31775a07ccdcfaf5c02.tar.gz
gentoo-927d13562b65ccd464d2b31775a07ccdcfaf5c02.tar.bz2
gentoo-927d13562b65ccd464d2b31775a07ccdcfaf5c02.zip
app-misc/ranger: update to EAPI 7 and add py38 support
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-misc/ranger')
-rw-r--r--app-misc/ranger/ranger-1.9.2.ebuild13
-rw-r--r--app-misc/ranger/ranger-9999.ebuild13
2 files changed, 8 insertions, 18 deletions
diff --git a/app-misc/ranger/ranger-1.9.2.ebuild b/app-misc/ranger/ranger-1.9.2.ebuild
index 3cbf21455d04..48aa1b9e69ef 100644
--- a/app-misc/ranger/ranger-1.9.2.ebuild
+++ b/app-misc/ranger/ranger-1.9.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
PYTHON_REQ_USE="ncurses"
inherit distutils-r1
@@ -19,11 +19,10 @@ DESCRIPTION="A vim-inspired file manager for the console"
HOMEPAGE="https://ranger.github.io/"
LICENSE="GPL-3"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="virtual/pager"
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
src_prepare() {
# use versioned doc path
@@ -32,10 +31,6 @@ src_prepare() {
distutils-r1_src_prepare
}
-python_test() {
- py.test -v tests/ranger || die "Tests failed under ${EPYTHON}"
-}
-
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "Ranger has many optional dependencies to support enhanced file previews."
diff --git a/app-misc/ranger/ranger-9999.ebuild b/app-misc/ranger/ranger-9999.ebuild
index 6d89ea92ccb9..ab9b014fc86d 100644
--- a/app-misc/ranger/ranger-9999.ebuild
+++ b/app-misc/ranger/ranger-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
PYTHON_REQ_USE="ncurses"
inherit distutils-r1
@@ -19,11 +19,10 @@ DESCRIPTION="A vim-inspired file manager for the console"
HOMEPAGE="https://ranger.github.io/"
LICENSE="GPL-3"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="virtual/pager"
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
src_prepare() {
# use versioned doc path
@@ -32,10 +31,6 @@ src_prepare() {
distutils-r1_src_prepare
}
-python_test() {
- py.test -v tests/ranger || die "Tests failed under ${EPYTHON}"
-}
-
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "Ranger has many optional dependencies to support enhanced file previews."