summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-09-20 16:15:07 +0200
committerSebastian Pipping <sping@gentoo.org>2021-09-20 16:15:07 +0200
commite7a2791f27d826179d33fe0afd4b7abf148c7413 (patch)
treef836490f7cd35487152b9375340a139037119c10 /app-misc/resolve-march-native
parentprofiles: Mask app-editors/emacs[svg] on m68k (diff)
downloadgentoo-e7a2791f27d826179d33fe0afd4b7abf148c7413.tar.gz
gentoo-e7a2791f27d826179d33fe0afd4b7abf148c7413.tar.bz2
gentoo-e7a2791f27d826179d33fe0afd4b7abf148c7413.zip
app-misc/resolve-march-native: py3.10 + DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/814032 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.23, Repoman-3.0.3
Diffstat (limited to 'app-misc/resolve-march-native')
-rw-r--r--app-misc/resolve-march-native/resolve-march-native-1.0.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-misc/resolve-march-native/resolve-march-native-1.0.0-r1.ebuild b/app-misc/resolve-march-native/resolve-march-native-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..351eb554727a
--- /dev/null
+++ b/app-misc/resolve-march-native/resolve-march-native-1.0.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Resolve GCC flag -march=native"
+HOMEPAGE="https://github.com/hartwork/resolve-march-native"
+SRC_URI="https://github.com/hartwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sys-devel/gcc-4.2"
+
+distutils_enable_tests pytest