summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/slashtime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/slashtime')
-rw-r--r--app-misc/slashtime/Manifest1
-rw-r--r--app-misc/slashtime/metadata.xml6
-rw-r--r--app-misc/slashtime/slashtime-0.5.13-r1.ebuild50
3 files changed, 57 insertions, 0 deletions
diff --git a/app-misc/slashtime/Manifest b/app-misc/slashtime/Manifest
new file mode 100644
index 000000000000..4d9e430f1b52
--- /dev/null
+++ b/app-misc/slashtime/Manifest
@@ -0,0 +1 @@
+DIST slashtime-0.5.13.tar.bz2 51154 SHA256 19b1d589142258d70d72eba043545667a305360ca9ff5ee78109a17a3076804d SHA512 bb80965882c8078aa7830d0d0bffa48c84ad455f7882500f68c100e65ff0978d5825dff9b8feb1daa0b3557a68c8d6162b0761bdb424f36a94e934ee1b616f59 WHIRLPOOL d88f0f8f6536102122bfcd570bb820e6b23eec8a09a5599e21d066109c6f43ddfe09a97773e904502b7e1d4c50cc00fe8642df1f038a06de5d1349b72ecce570
diff --git a/app-misc/slashtime/metadata.xml b/app-misc/slashtime/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/app-misc/slashtime/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+
diff --git a/app-misc/slashtime/slashtime-0.5.13-r1.ebuild b/app-misc/slashtime/slashtime-0.5.13-r1.ebuild
new file mode 100644
index 000000000000..ddd6d9c5a7b2
--- /dev/null
+++ b/app-misc/slashtime/slashtime-0.5.13-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2
+
+DESCRIPTION="View the time at locations around the world"
+HOMEPAGE="http://research.operationaldynamics.com/projects/slashtime/"
+SRC_URI="http://research.operationaldynamics.com/projects/${PN}/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+COMMON_DEP="dev-java/java-gnome:4.1"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+src_configure() {
+ # Handwritten in perl so not using econf
+ ./configure prefix=/usr jardir=/usr/share/${PN}/lib || die
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ # This is needed to generate the slashtime jar.
+ emake -j1 DESTDIR="${D}" install
+
+ java-pkg_register-dependency java-gnome-4.1 gtk.jar
+ java-pkg_regjar /usr/share/${PN}/lib/${PN}.jar
+
+ # Replace slashtime launcher with our own.
+ rm "${D}"/usr/bin/slashtime || die
+ java-pkg_dolauncher ${PN} --main slashtime.client.Master --pwd /usr
+
+ dodoc AUTHORS HACKING PLACES README TODO
+
+ use source && java-pkg_dosrc src/java/slashtime
+}