summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/spacenavd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/spacenavd/files')
-rw-r--r--app-misc/spacenavd/files/99-space-navigator.rules6
-rw-r--r--app-misc/spacenavd/files/99-space-navigator.rules-r17
-rw-r--r--app-misc/spacenavd/files/spacenavd-0.5-custom-flags.patch67
-rw-r--r--app-misc/spacenavd/files/spacenavd-0.5-destdir.patch16
-rw-r--r--app-misc/spacenavd/files/spacenavd-0.5-no-x11.patch13
-rw-r--r--app-misc/spacenavd/files/spacenavd.service8
-rw-r--r--app-misc/spacenavd/files/spnavd27
7 files changed, 144 insertions, 0 deletions
diff --git a/app-misc/spacenavd/files/99-space-navigator.rules b/app-misc/spacenavd/files/99-space-navigator.rules
new file mode 100644
index 000000000000..a5e8f0b65305
--- /dev/null
+++ b/app-misc/spacenavd/files/99-space-navigator.rules
@@ -0,0 +1,6 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2 or later
+# $Id$
+
+# Start daemon on insertion of a SpaceNavigator device
+SUBSYSTEM=="usb", ACTION=="add", ATTRS{manufacturer}=="3Dconnexion", ATTRS{product}=="Space Navigator", RUN+="/etc/init.d/spacenavd --quiet start"
diff --git a/app-misc/spacenavd/files/99-space-navigator.rules-r1 b/app-misc/spacenavd/files/99-space-navigator.rules-r1
new file mode 100644
index 000000000000..8135060fbf23
--- /dev/null
+++ b/app-misc/spacenavd/files/99-space-navigator.rules-r1
@@ -0,0 +1,7 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2 or later
+# $Id$
+
+# Start daemon on insertion of a SpaceNavigator device
+SUBSYSTEM=="usb", ACTION=="add", ATTRS{manufacturer}=="3Dconnexion", ATTRS{product}=="Space Navigator", RUN+="/etc/init.d/spacenavd --quiet start"
+SUBSYSTEM=="usb", ACTION=="add", ATTRS{manufacturer}=="3Dconnexion", ATTRS{product}=="SpaceNavigator", TAG+="systemd", ENV{SYSTEMD_WANTS}+="spacenavd.service"
diff --git a/app-misc/spacenavd/files/spacenavd-0.5-custom-flags.patch b/app-misc/spacenavd/files/spacenavd-0.5-custom-flags.patch
new file mode 100644
index 000000000000..3b834a43952d
--- /dev/null
+++ b/app-misc/spacenavd/files/spacenavd-0.5-custom-flags.patch
@@ -0,0 +1,67 @@
+diff -Npur spacenavd-0.5.orig/Makefile.in spacenavd-0.5/Makefile.in
+--- spacenavd-0.5.orig/Makefile.in 2012-01-31 22:22:20.460368687 +0100
++++ spacenavd-0.5/Makefile.in 2012-01-31 22:23:18.170367675 +0100
+@@ -6,8 +6,8 @@ ctl = spnavd_ctl
+
+ CC = gcc
+ INSTALL = install
+-CFLAGS = -pedantic -Wall $(dbg) $(opt) -fno-strict-aliasing -I$(srcdir)/src
+-LDFLAGS = $(xlib)
++CFLAGS = $(opt) -fno-strict-aliasing -I$(srcdir)/src
++LDFLAGS = $(ldopt) $(xlib)
+
+ $(bin): $(obj)
+ $(CC) -o $@ $(obj) $(LDFLAGS)
+diff -Npur spacenavd-0.5.orig/configure spacenavd-0.5/configure
+--- spacenavd-0.5.orig/configure 2012-01-31 22:22:20.460368687 +0100
++++ spacenavd-0.5/configure 2012-01-31 22:22:49.257368187 +0100
+@@ -28,6 +28,7 @@ test_kver() {
+
+ PREFIX=/usr/local
+ OPT=yes
++LDOPT=yes
+ DBG=yes
+ X11=yes
+ HOTPLUG=yes
+@@ -70,6 +71,11 @@ for arg; do
+ --disable-opt)
+ OPT=no;;
+
++ --enable-ldopt)
++ LDOPT=yes;;
++ --disable-ldopt)
++ LDOPT=no;;
++
+ --enable-debug)
+ DBG=yes;;
+ --disable-debug)
+@@ -95,6 +101,8 @@ for arg; do
+ echo ' --disable-hotplug: disable hotplug, fallback to polling for the device'
+ echo ' --enable-opt: enable speed optimizations (default)'
+ echo ' --disable-opt: disable speed optimizations'
++ echo ' --enable-ldopt: enable link optimizations (default)'
++ echo ' --disable-ldopt: disable link optimizations'
+ echo ' --enable-debug: include debugging symbols (default)'
+ echo ' --disable-debug: do not include debugging symbols'
+ echo 'all invalid options are silently ignored'
+@@ -105,6 +113,7 @@ done
+
+ echo " prefix: $PREFIX"
+ echo " optimize for speed: $OPT"
++echo " optimize link: $LDOPT"
+ echo " include debugging symbols: $DBG"
+ echo " x11 communication method: $X11"
+ echo " use hotplug: $HOTPLUG"
+@@ -128,7 +137,11 @@ if [ "$DBG" = 'yes' ]; then
+ fi
+
+ if [ "$OPT" = 'yes' ]; then
+- echo 'opt = -O3' >>Makefile
++ echo "opt = ${CFLAGS:--O3}" >>Makefile
++fi
++
++if [ "$LDOPT" = 'yes' ]; then
++ echo "ldopt = ${LDFLAGS}" >>Makefile
+ fi
+
+ if [ "$X11" = 'yes' ]; then
diff --git a/app-misc/spacenavd/files/spacenavd-0.5-destdir.patch b/app-misc/spacenavd/files/spacenavd-0.5-destdir.patch
new file mode 100644
index 000000000000..5b2372242e14
--- /dev/null
+++ b/app-misc/spacenavd/files/spacenavd-0.5-destdir.patch
@@ -0,0 +1,16 @@
+diff -Npur spacenavd-0.5.orig/Makefile.in spacenavd-0.5/Makefile.in
+--- spacenavd-0.5.orig/Makefile.in 2011-11-16 21:43:53.210859753 +0100
++++ spacenavd-0.5/Makefile.in 2011-11-16 21:45:36.386857932 +0100
+@@ -24,9 +24,9 @@ clean:
+
+ .PHONY: install
+ install: $(bin)
+- $(INSTALL) -d $(PREFIX)/bin
+- $(INSTALL) -m 755 $(bin) $(PREFIX)/bin/$(bin)
+- $(INSTALL) -m 755 $(srcdir)/$(ctl) $(PREFIX)/bin/$(ctl)
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
++ $(INSTALL) -m 755 $(bin) $(DESTDIR)$(PREFIX)/bin/$(bin)
++ $(INSTALL) -m 755 $(srcdir)/$(ctl) $(DESTDIR)$(PREFIX)/bin/$(ctl)
+ cd $(srcdir) && ./setup_init --no-install
+
+ # [ -d /etc/hal/fdi/policy ] && \
diff --git a/app-misc/spacenavd/files/spacenavd-0.5-no-x11.patch b/app-misc/spacenavd/files/spacenavd-0.5-no-x11.patch
new file mode 100644
index 000000000000..bbdd7d6196ec
--- /dev/null
+++ b/app-misc/spacenavd/files/spacenavd-0.5-no-x11.patch
@@ -0,0 +1,13 @@
+diff -Npur spacenavd-0.5.old/src/event.c spacenavd-0.5/src/event.c
+--- src/event.c 2012-03-21 22:15:37.093401293 +0100
++++ src/event.c 2012-03-21 22:14:10.734401301 +0100
+@@ -20,7 +20,9 @@ along with this program. If not, see <h
+ #include <stdlib.h>
+ #include "event.h"
+ #include "client.h"
++#ifdef USE_X11
+ #include "proto_x11.h"
++#endif
+ #include "proto_unix.h"
+ #include "spnavd.h"
+
diff --git a/app-misc/spacenavd/files/spacenavd.service b/app-misc/spacenavd/files/spacenavd.service
new file mode 100644
index 000000000000..b9b14d80086a
--- /dev/null
+++ b/app-misc/spacenavd/files/spacenavd.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=3Dconnexion Input Devices Userspace Driver
+
+[Service]
+ExecStart=/usr/bin/spacenavd -d
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-misc/spacenavd/files/spnavd b/app-misc/spacenavd/files/spnavd
new file mode 100644
index 000000000000..383a2adc390f
--- /dev/null
+++ b/app-misc/spacenavd/files/spnavd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need localmount
+ after bootmisc
+}
+
+start() {
+ ebegin "Starting Spacenav system daemon"
+
+ start-stop-daemon --start --pidfile /var/run/spnavd.pid --exec /usr/bin/spacenavd
+ eend $?
+}
+
+stop() {
+ local retval
+
+ ebegin "Stopping Spacenav system daemon"
+
+ start-stop-daemon --stop --pidfile /var/run/spnavd.pid
+ retval=$?
+
+ eend ${retval}
+ return ${retval}
+}