summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya Kodi <contact@thamognya.com>2022-04-24 00:04:18 +0700
committerJoonas Niilola <juippis@gentoo.org>2022-05-01 19:32:35 +0300
commite3721510789d3ab2413d18800286a368a93fe164 (patch)
treefd408db4dcd756c02ab43ce49993aab5ff4621e9 /app-misc/terminal-colors
parentwww-apps/gitea: bump to 1.16.6 (diff)
downloadgentoo-e3721510789d3ab2413d18800286a368a93fe164.tar.gz
gentoo-e3721510789d3ab2413d18800286a368a93fe164.tar.bz2
gentoo-e3721510789d3ab2413d18800286a368a93fe164.zip
app-misc/terminal-colors: Bump to version 3.0.2 and 9999
Signed-off-by: Thamognya Kodi <contact@thamognya.com> Closes: https://github.com/gentoo/gentoo/pull/25170 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/terminal-colors')
-rw-r--r--app-misc/terminal-colors/Manifest1
-rw-r--r--app-misc/terminal-colors/metadata.xml12
-rw-r--r--app-misc/terminal-colors/terminal-colors-3.0.2.ebuild32
-rw-r--r--app-misc/terminal-colors/terminal-colors-9999.ebuild32
4 files changed, 76 insertions, 1 deletions
diff --git a/app-misc/terminal-colors/Manifest b/app-misc/terminal-colors/Manifest
index 78436c9dfdb1..7afd13d35f4b 100644
--- a/app-misc/terminal-colors/Manifest
+++ b/app-misc/terminal-colors/Manifest
@@ -1 +1,2 @@
DIST terminal-colors-2.3.gz 5424 BLAKE2B e08635c0e989a430805159829b133f18b7c30959c945e4373a77442ac15628bb8bf3a5a2d14cd4f5705a5dd332297fa3d41611b52f56baaf9b1a882c26626714 SHA512 64fbfe766563c4c25bec23d1657187414f97b6f92e8a4a35337563210ef9873db495376676ef0a2f4e440ad77a6c1b43ee9c27fe04b34c2839eb4fffd5289a00
+DIST terminal-colors-3.0.2.tar.gz 152226 BLAKE2B 95179e27f4e1af1008dd0da01917aad1c7e4d192f9cfe30a18c1f24b7a038b4cd88349f8c7f2f84bfd8bc1ef53f558579275e9c31a6d76414d241a3f3186bafd SHA512 517506b7508251eeb151032b8071e4225efb19207b4b50aee2ad5b9a58063ce78c39f7193135ca66669d88bc1d6cc54b614d1584d877d1891f35541c7b3bb4a1
diff --git a/app-misc/terminal-colors/metadata.xml b/app-misc/terminal-colors/metadata.xml
index 85e4ed814fa2..57ed3913755b 100644
--- a/app-misc/terminal-colors/metadata.xml
+++ b/app-misc/terminal-colors/metadata.xml
@@ -1,5 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <name>Thamognya Kodi</name>
+ <email>contact@thamognya.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">eikenb/terminal-colors</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-misc/terminal-colors/terminal-colors-3.0.2.ebuild b/app-misc/terminal-colors/terminal-colors-3.0.2.ebuild
new file mode 100644
index 000000000000..867968e5c559
--- /dev/null
+++ b/app-misc/terminal-colors/terminal-colors-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit python-r1
+
+DESCRIPTION="A tool to display color charts for 8, 16, 88, and 256 color terminals"
+HOMEPAGE="http://zhar.net/projects/shell/terminal-colors"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/eikenb/terminal-colors.git"
+else
+ SRC_URI="https://github.com/eikenb/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x64-macos"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_compile() { :; }
+
+src_install() {
+ python_foreach_impl python_newscript ${PN} ${PN}
+ einstalldocs
+}
diff --git a/app-misc/terminal-colors/terminal-colors-9999.ebuild b/app-misc/terminal-colors/terminal-colors-9999.ebuild
new file mode 100644
index 000000000000..867968e5c559
--- /dev/null
+++ b/app-misc/terminal-colors/terminal-colors-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit python-r1
+
+DESCRIPTION="A tool to display color charts for 8, 16, 88, and 256 color terminals"
+HOMEPAGE="http://zhar.net/projects/shell/terminal-colors"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/eikenb/terminal-colors.git"
+else
+ SRC_URI="https://github.com/eikenb/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x64-macos"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_compile() { :; }
+
+src_install() {
+ python_foreach_impl python_newscript ${PN} ${PN}
+ einstalldocs
+}