summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/tmux/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/tmux/files')
-rw-r--r--app-misc/tmux/files/tmux-1.9a-flags.patch28
-rw-r--r--app-misc/tmux/files/tmux-2.0-flags.patch18
-rw-r--r--app-misc/tmux/files/tmux.vim1
3 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/tmux/files/tmux-1.9a-flags.patch b/app-misc/tmux/files/tmux-1.9a-flags.patch
new file mode 100644
index 000000000000..8bf21d86ed6c
--- /dev/null
+++ b/app-misc/tmux/files/tmux-1.9a-flags.patch
@@ -0,0 +1,28 @@
+--- tmux-1.9a/Makefile.am
++++ tmux-1.9a/Makefile.am
+@@ -27,23 +27,20 @@
+ if IS_GCC
+ CFLAGS += -std=gnu99
+ if IS_DEBUG
+-CFLAGS += -O0 -g
+ CFLAGS += -Wno-long-long -Wall -W -Wnested-externs -Wformat=2
+ CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
+ CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
+ CFLAGS += -Wundef -Wbad-function-cast -Winline -Wcast-align
+ CFLAGS += -Wdeclaration-after-statement
+ CPPFLAGS += -DDEBUG
+-else
+-CFLAGS += -O2
+ endif
+ if IS_GCC4
+-CPPFLAGS += -iquote. -I/usr/local/include
++CPPFLAGS += -iquote.
+ if IS_DEBUG
+ CFLAGS += -Wno-pointer-sign
+ endif
+ else
+-CPPFLAGS += -I. -I- -I/usr/local/include
++CPPFLAGS += -I. -I-
+ endif
+ endif
+
diff --git a/app-misc/tmux/files/tmux-2.0-flags.patch b/app-misc/tmux/files/tmux-2.0-flags.patch
new file mode 100644
index 000000000000..d2c40e04b788
--- /dev/null
+++ b/app-misc/tmux/files/tmux-2.0-flags.patch
@@ -0,0 +1,18 @@
+ Makefile.am | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 63e20b1..a2fec1e 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -25,9 +25,8 @@ endif
+ # Set flags for gcc. gcc4 whines abouts silly stuff so it needs slightly
+ # different flags.
+ if IS_GCC
+-CFLAGS += -std=gnu99 -O2
++CFLAGS += -std=gnu99
+ if IS_DEBUG
+-CFLAGS += -g
+ CFLAGS += -Wno-long-long -Wall -W -Wnested-externs -Wformat=2
+ CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
+ CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
diff --git a/app-misc/tmux/files/tmux.vim b/app-misc/tmux/files/tmux.vim
new file mode 100644
index 000000000000..baac50adab16
--- /dev/null
+++ b/app-misc/tmux/files/tmux.vim
@@ -0,0 +1 @@
+au BufNewFile,BufRead .tmux.conf*,tmux.conf* setf tmux