summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-01-29 22:32:46 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-29 22:33:08 +0100
commitc24a30d6ce67243dd8589592d15b3a0eba3a0bf9 (patch)
treed65f4f01920256c5c5746bae9ae4b8b233f7385f /app-misc/todo/todo-2.10.ebuild
parentdev-libs/libnl: Replace in6.h patch with complete upstream patch. (diff)
downloadgentoo-c24a30d6ce67243dd8589592d15b3a0eba3a0bf9.tar.gz
gentoo-c24a30d6ce67243dd8589592d15b3a0eba3a0bf9.tar.bz2
gentoo-c24a30d6ce67243dd8589592d15b3a0eba3a0bf9.zip
app-misc/todo: new package.
todo is a CLI-based TODO list manager written in Bash. Gentoo-Bug: https://bugs.gentoo.org/149233 Package-Manager: portage-2.3.3
Diffstat (limited to 'app-misc/todo/todo-2.10.ebuild')
-rw-r--r--app-misc/todo/todo-2.10.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/todo/todo-2.10.ebuild b/app-misc/todo/todo-2.10.ebuild
new file mode 100644
index 000000000000..c8eefae79b64
--- /dev/null
+++ b/app-misc/todo/todo-2.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="A CLI-based TODO list manager"
+HOMEPAGE="http://todotxt.com/"
+SRC_URI="https://github.com/ginatrapani/${PN}.txt-cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="app-shells/bash"
+
+S="${WORKDIR}/${PN}.txt-cli-${PV}"
+
+DOCS=( README.textile CONTRIBUTING.md LICENSE todo.cfg )
+
+src_test() {
+ make test || die "tests failed"
+}
+
+src_install() {
+ newbin "${PN}.sh" "${PN}"
+ newbashcomp "${PN}_completion" "${PN}"
+ einstalldocs
+}