summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-04-08 23:56:11 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-04-08 23:56:11 +0200
commit3ab41e097caa4a39f508aee73da35d51bb9d69c4 (patch)
treed9bb2f7b27fe35761d58d2df42ae1d104beec065 /app-misc/todo
parentdev-lang/parrot: fix toolong DESCRIPTION. (diff)
downloadgentoo-3ab41e097caa4a39f508aee73da35d51bb9d69c4.tar.gz
gentoo-3ab41e097caa4a39f508aee73da35d51bb9d69c4.tar.bz2
gentoo-3ab41e097caa4a39f508aee73da35d51bb9d69c4.zip
app-misc/todo: add patch to fix bash completion.
Courtesy of Ferenc Erki <erkiferenc@gmail.com>. Gentoo-Bug: https://bugs.gentoo.org/614400 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-misc/todo')
-rw-r--r--app-misc/todo/files/todo-2.10-fix-bash-completion.patch12
-rw-r--r--app-misc/todo/todo-2.10-r1.ebuild35
2 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/todo/files/todo-2.10-fix-bash-completion.patch b/app-misc/todo/files/todo-2.10-fix-bash-completion.patch
new file mode 100644
index 000000000000..7e6de2f10568
--- /dev/null
+++ b/app-misc/todo/files/todo-2.10-fix-bash-completion.patch
@@ -0,0 +1,12 @@
+--- ./todo_completion 2017-04-08 15:18:23.102736966 +0200
++++ ./todo_completion 2017-04-08 15:18:56.839725605 +0200
+@@ -85,6 +85,9 @@
+ }
+ complete -F _todo todo.sh
+
++# Gentoo bug 614400
++complete -F _todo todotxt
++
+ # If you define an alias (e.g. "t") to todo.sh, you need to explicitly enable
+ # completion for it, too:
+ #complete -F _todo t
diff --git a/app-misc/todo/todo-2.10-r1.ebuild b/app-misc/todo/todo-2.10-r1.ebuild
new file mode 100644
index 000000000000..5fa2cd242a92
--- /dev/null
+++ b/app-misc/todo/todo-2.10-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="A CLI-based TODO list manager"
+HOMEPAGE="http://todotxt.com/"
+SRC_URI="https://github.com/ginatrapani/${PN}.txt-cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="app-shells/bash"
+
+PATCHES=( "${FILESDIR}/${P}-fix-bash-completion.patch" )
+
+S="${WORKDIR}/${PN}.txt-cli-${PV}"
+
+DOCS=( README.textile CONTRIBUTING.md LICENSE todo.cfg )
+
+src_test() {
+ make test || die "tests failed"
+}
+
+src_install() {
+ dobin "${PN}.sh"
+ dosym "/usr/bin/${PN}.sh" "/usr/bin/${PN}txt"
+ newbashcomp "${PN}_completion" "${PN}.sh"
+ bashcomp_alias "${PN}.sh" "${PN}txt"
+ einstalldocs
+}