summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/ttysnoop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/ttysnoop')
-rw-r--r--app-misc/ttysnoop/Manifest1
-rw-r--r--app-misc/ttysnoop/files/pinkbyte_masking.patch41
-rw-r--r--app-misc/ttysnoop/files/ttysnoop-makefile.patch36
-rw-r--r--app-misc/ttysnoop/metadata.xml8
-rw-r--r--app-misc/ttysnoop/ttysnoop-0.12d.ebuild45
5 files changed, 131 insertions, 0 deletions
diff --git a/app-misc/ttysnoop/Manifest b/app-misc/ttysnoop/Manifest
new file mode 100644
index 000000000000..a8a55d00231c
--- /dev/null
+++ b/app-misc/ttysnoop/Manifest
@@ -0,0 +1 @@
+DIST ttysnoop-0.12d.k26.tar.gz 9376 SHA256 250d7027af95f49f7d081a42878bf13b393db8e4475120278bb5e2a820fb6249 SHA512 9ac90ce08e170442718ca4871b7cb569acd8a594e63a56a6889ff0852be93a6ae8e7a212ba1064e74286043dad5a27af5d8588cb3b1ea297db4bf7fa10c66665 WHIRLPOOL c11cced3730e5591c2f4d3920a39a2a58177d4889e1b3cd7d2aedb46d15937637cc64fe2ed1412d6481adccd9459204097ffd62e59cd85687fd9f6263ad2830f
diff --git a/app-misc/ttysnoop/files/pinkbyte_masking.patch b/app-misc/ttysnoop/files/pinkbyte_masking.patch
new file mode 100644
index 000000000000..a0539c239b04
--- /dev/null
+++ b/app-misc/ttysnoop/files/pinkbyte_masking.patch
@@ -0,0 +1,41 @@
+--- ttysnoops.c 2009-08-13 17:11:30.705202250 +0400
++++ ttysnoops.c 2009-08-13 17:17:29.989201055 +0400
+@@ -18,6 +18,7 @@
+ v0.12d 8-4-98 Carl Declerck - updated #includes a bit
+ k26 28-5-00 Vinicius Anselmo - added sound alert (demoniac) created by Stas
+ k26 31-5-04 Vinicius Anselmo - updated for unix98 pty support
++ k26 13-8-09 Pinkbyte - deleted fucking sound alert and "bye bye" message ;)
+ */
+
+ #include <sys/types.h>
+@@ -502,22 +503,6 @@
+ struct utmp utmp;
+ int ptyfd, servfd, len, n, sel, susp = 0;
+
+- /* demoniac begin */
+-
+- StopHandle();
+-
+- if (InitSound()) /* play if we can */
+- {
+- DoSound(466, SLEN); // A#4
+- DoSound(622, SLEN); // D#5
+- DoSound(784, SLEN); // G5
+- DoSound(932, SLEN*2); // A#5
+- DoSound(784, SLEN); // G5
+- DoSound(932, SLEN*3); // A#5
+- }
+-
+- /* demoniac end */
+-
+ if (!isatty(STDIN_FILENO))
+ errorf ("stdin is not a tty\n");
+
+@@ -660,7 +645,6 @@
+ {
+ if ((n = read(ptyfd, buff, BUFF_SIZE)) < 1)
+ {
+- errorf ("bye bye\n");
+ exit (0);
+ }
+
diff --git a/app-misc/ttysnoop/files/ttysnoop-makefile.patch b/app-misc/ttysnoop/files/ttysnoop-makefile.patch
new file mode 100644
index 000000000000..54d04dd40a29
--- /dev/null
+++ b/app-misc/ttysnoop/files/ttysnoop-makefile.patch
@@ -0,0 +1,36 @@
+--- Makefile 2004-06-07 04:27:40.000000000 +0400
++++ Makefile 2011-07-21 11:50:22.580167326 +0400
+@@ -11,7 +11,7 @@
+
+ # For shadow support
+
+-CCOPTS = -O2 -DSHADOW_PWD
++CCOPTS = -DSHADOW_PWD
+ LIBS = -lcrypt
+ #LIBS = -lshadow
+
+@@ -24,19 +24,19 @@
+ all: ttysnoops ttysnoop
+
+ ttysnoops: $(SERVEROBJS)
+- $(CC) $(SERVEROBJS) -o ttysnoops $(LIBS)
++ $(CC) $(SERVEROBJS) -o ttysnoops $(LDFLAGS) $(LIBS)
+
+ ttysnoop: $(CLIENTOBJS)
+- $(CC) $(CLIENTOBJS) -o ttysnoop $(LIBS)
++ $(CC) $(CLIENTOBJS) -o ttysnoop $(LDFLAGS) $(LIBS)
+
+ ttysnoops.o: $(SERVERSRCS) $(INCLUDES)
+- $(CC) $(CCOPTS) -c -o ttysnoops.o $(SERVERSRCS)
++ $(CC) $(CCOPTS) $(CFLAGS) -c -o ttysnoops.o $(SERVERSRCS)
+
+ ttysnoop.o: $(CLIENTSRCS) $(INCLUDES)
+- $(CC) $(CCOPTS) -c -o ttysnoop.o $(CLIENTSRCS)
++ $(CC) $(CCOPTS) $(CFLAGS) -c -o ttysnoop.o $(CLIENTSRCS)
+
+ common.o: common.c common.h
+- $(CC) $(CCOPTS) -c -o common.o common.c
++ $(CC) $(CCOPTS) $(CFLAGS) -c -o common.o common.c
+
+ clean:
+ rm -f *.o core ttysnoop ttysnoops
diff --git a/app-misc/ttysnoop/metadata.xml b/app-misc/ttysnoop/metadata.xml
new file mode 100644
index 000000000000..b6b8956cde34
--- /dev/null
+++ b/app-misc/ttysnoop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/ttysnoop/ttysnoop-0.12d.ebuild b/app-misc/ttysnoop/ttysnoop-0.12d.ebuild
new file mode 100644
index 000000000000..072f2d0f98b3
--- /dev/null
+++ b/app-misc/ttysnoop/ttysnoop-0.12d.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+MY_P="${P}.k26"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool to snoop on login tty's through another tty-device or pseudo-tty"
+HOMEPAGE="http://sysd.org/stas/node/35"
+SRC_URI="http://sysd.org/stas/files/active/0/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="README snooptab.dist"
+
+src_prepare(){
+ epatch "${FILESDIR}"/pinkbyte_masking.patch
+ epatch "${FILESDIR}"/"${PN}"-makefile.patch
+}
+
+src_compile(){
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dodir /var/spool/ttysnoop
+ fperms o= /var/spool/ttysnoop
+ dodoc ${DOCS}
+ dosbin ttysnoop
+ dosbin ttysnoops
+ doman ttysnoop.8
+ insinto /etc
+ newins snooptab.dist snooptab
+}