summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/unfoo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/unfoo')
-rw-r--r--app-misc/unfoo/Manifest1
-rw-r--r--app-misc/unfoo/metadata.xml11
-rw-r--r--app-misc/unfoo/unfoo-1.0.8.ebuild52
3 files changed, 64 insertions, 0 deletions
diff --git a/app-misc/unfoo/Manifest b/app-misc/unfoo/Manifest
new file mode 100644
index 000000000000..60b39fc2752b
--- /dev/null
+++ b/app-misc/unfoo/Manifest
@@ -0,0 +1 @@
+DIST unfoo-1.0.8.tar.gz 31862 SHA256 badc62603f1f7293032b36a1a3f1051b715b31895700d116d74cba4cb68af1e5 SHA512 b4a2489ca4ae5a81feacc57aa7c9c6437e3fbb0cec997d1b5e182e9ea7e19c13998968f23094e78908e6d41e699d50a1353ae475ec32146c63298eff06182281 WHIRLPOOL a6ab9fe60f73d07753760cba5d6d9d9ed7694fc1fba233c0510b823e1ad6f8e539207815543c690072545178841336d853ae6378fa88dc63e7668d1c3d266205
diff --git a/app-misc/unfoo/metadata.xml b/app-misc/unfoo/metadata.xml
new file mode 100644
index 000000000000..01018901a9f6
--- /dev/null
+++ b/app-misc/unfoo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <use>
+ <flag name="minimal">Do not install all support archive binaries</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">jlec/unfoo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/unfoo/unfoo-1.0.8.ebuild b/app-misc/unfoo/unfoo-1.0.8.ebuild
new file mode 100644
index 000000000000..43ee3a57b7c7
--- /dev/null
+++ b/app-misc/unfoo/unfoo-1.0.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A simple bash driven frontend to simplify decompression of files"
+HOMEPAGE="http://obsoleet.org/code/unfoo"
+SRC_URI="https://github.com/jlec/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~s390 x86 ~amd64-linux ~x86-linux"
+IUSE="+minimal test"
+
+COMMON_DEPS="
+ || (
+ app-arch/bzip2
+ app-arch/lbzip2[symlink]
+ app-arch/pbzip2[symlink] )
+ || (
+ app-arch/gzip
+ app-arch/pigz[symlink] )
+ app-arch/p7zip
+ || (
+ app-arch/rar
+ app-arch/unrar-gpl
+ app-arch/unrar )
+ app-arch/unace
+ app-arch/unzip
+ app-arch/xz-utils"
+RDEPEND="!minimal? ( ${COMMON_DEPS} )"
+DEPEND="test? ( ${COMMON_DEPS} )"
+
+src_compile() { :; }
+
+src_install() {
+ dodoc README*
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ echo
+ elog "unfoo can handle far more than just .tar*, but it requires some"
+ elog "optional packages to do so. For a list, either consult the source"
+ elog "(less /usr/bin/unfoo), or see http://obsoleet.org/code/unfoo"
+ elog "To get full support please use USE=-minimal"
+ elif [[ ${REPLACING_VERSIONS} < 1.0.7 ]]; then
+ elog "To get full support please use USE=-minimal"
+ fi
+}