summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/zisofs-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/zisofs-tools')
-rw-r--r--app-misc/zisofs-tools/Manifest2
-rw-r--r--app-misc/zisofs-tools/metadata.xml5
-rw-r--r--app-misc/zisofs-tools/zisofs-tools-1.0.6.ebuild27
-rw-r--r--app-misc/zisofs-tools/zisofs-tools-1.0.8.ebuild27
4 files changed, 61 insertions, 0 deletions
diff --git a/app-misc/zisofs-tools/Manifest b/app-misc/zisofs-tools/Manifest
new file mode 100644
index 000000000000..88c1e63f260a
--- /dev/null
+++ b/app-misc/zisofs-tools/Manifest
@@ -0,0 +1,2 @@
+DIST zisofs-tools-1.0.6.tar.bz2 53138 SHA256 a7d80141be2b52df99423cc617ad9dab8e81b1c79ca437789bbb1a9433524e3e SHA512 7928c40bd421853adde1da874a574ccaaa2b9ac3cb6d0fe241763bb64f66717dd83991f92bad093a1044e35f72f84643568af4a4999cfe62b85777df24fc0b96 WHIRLPOOL eb3a0ed0394bba3a2dc4f51aba0a2071b4f69db997f46f577550afbe296dbbede564641cc29d5b8d032ab8e1cc9ea90abbc3f43aa33984d564def8aadfd3eddf
+DIST zisofs-tools-1.0.8.tar.bz2 52968 SHA256 ae4e53e4914934d41660248fb59d3c8761f1f1fd180d5ec993c17ddb3afd04f3 SHA512 2c50bb73428c065e02e95def81950e1f64aff3cec0a4d74ee91ddbf4c15b81a423d8a128a4abc2e11aeb866b9d5f67f55019f7ae884c9e1a8b013ed3133db50d WHIRLPOOL 05b59ba8423be7ac1f257ce6106f32be00cc62ffd2891c8f620e65b5eda28611aefd073f3832088bfcb42309d92e0b8866ed219b273b9d9431af928e032a061f
diff --git a/app-misc/zisofs-tools/metadata.xml b/app-misc/zisofs-tools/metadata.xml
new file mode 100644
index 000000000000..74d25af22b2e
--- /dev/null
+++ b/app-misc/zisofs-tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kernel-misc</herd>
+</pkgmetadata>
diff --git a/app-misc/zisofs-tools/zisofs-tools-1.0.6.ebuild b/app-misc/zisofs-tools/zisofs-tools-1.0.6.ebuild
new file mode 100644
index 000000000000..eb489423f2d6
--- /dev/null
+++ b/app-misc/zisofs-tools/zisofs-tools-1.0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic
+
+DESCRIPTION="User utilities for zisofs"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/fs/zisofs/"
+SRC_URI="mirror://kernel/linux/utils/fs/zisofs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="static"
+
+DEPEND=">=sys-libs/zlib-1.1.4"
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" install || die
+ dodoc CHANGES INSTALL README
+}
diff --git a/app-misc/zisofs-tools/zisofs-tools-1.0.8.ebuild b/app-misc/zisofs-tools/zisofs-tools-1.0.8.ebuild
new file mode 100644
index 000000000000..f3c0d05bd821
--- /dev/null
+++ b/app-misc/zisofs-tools/zisofs-tools-1.0.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic
+
+DESCRIPTION="User utilities for zisofs"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/fs/zisofs/"
+SRC_URI="mirror://kernel/linux/utils/fs/zisofs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos"
+IUSE="static"
+
+DEPEND=">=sys-libs/zlib-1.1.4"
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" install || die
+ dodoc CHANGES INSTALL README
+}