summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Herdiansyah <herdiansyah@openmailbox.org>2016-12-02 17:05:16 +0700
committerPatrice Clement <monsieurp@gentoo.org>2016-12-04 23:32:09 +0100
commit1aef5edb3f0528f5b234d079238c27f61903995f (patch)
tree6822ae22dfe3b20b2cbee3ed195efc04a3edae88 /app-misc
parentwww-client/chromium: remove old (diff)
downloadgentoo-1aef5edb3f0528f5b234d079238c27f61903995f.tar.gz
gentoo-1aef5edb3f0528f5b234d079238c27f61903995f.tar.bz2
gentoo-1aef5edb3f0528f5b234d079238c27f61903995f.zip
app-misc/neofetch: version bump to 2.0.
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2981
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/neofetch/Manifest1
-rw-r--r--app-misc/neofetch/neofetch-2.0.ebuild30
-rw-r--r--app-misc/neofetch/neofetch-9999.ebuild7
3 files changed, 33 insertions, 5 deletions
diff --git a/app-misc/neofetch/Manifest b/app-misc/neofetch/Manifest
index 2aca9280618c..41cf2dd33b54 100644
--- a/app-misc/neofetch/Manifest
+++ b/app-misc/neofetch/Manifest
@@ -1,2 +1,3 @@
DIST neofetch-1.8.1.tar.gz 52867 SHA256 dfa1e97f3a91af00da45af1bf3f6a197f545063dba129bd4db839b0139e68e24 SHA512 c89a5c2b01c75fdce66e901d95f19da7e7865bc708426a577b3d11bd383eb7261d1493eb06aa4da59c141bd0d5629a6dbdf1dcf334ea57a86ceab565de627f29 WHIRLPOOL f6de8f24f602298582d61a7932344cb4f3d0ddd197d7c948273f12e911a593059aead4dd598d54331d65aa0d6764386f5e268775dc19c0817b2201c13687af37
DIST neofetch-1.9.1.tar.gz 55739 SHA256 d7e30215994968ca861836f9bab9259624688fd50620e7d5af5c8b31da8bd32b SHA512 e5b339549bd5eae726e66369bd9ebae7927117d7fb5af52bdfa54d5bff0793d72ed893ed631999dd492a2044fcc91ffe990ae8113b40fa3d724f5584417defc9 WHIRLPOOL 74f35ede4b3836d4b5485df0a80a1a9fef0d23de637558456dac69bdf7f4a1742f7f2e87e4c0faa99bec5959145ea5cc8e764cde320f1005ec1263c0c808eaac
+DIST neofetch-2.0.tar.gz 57634 SHA256 27c208311d5aef8031987b689e3ba3f7663e5487273fa05698132a10a6ef4a48 SHA512 77eddfa6edd90976fe552d425bf130719715775082768b13cb55a203908b06858d8ba90098703a73b07fb13951a2ec1fb928492e1d74faa9866d3d36619afc0e WHIRLPOOL 8b286364f8d3a0ad0e5e60d2f64f78820cf4a1d3d816d9b4d3872595908e3599991d4f882796a9611e79583cd2b5d448bcbaa8029f66c52e005a9b6063cf88bb
diff --git a/app-misc/neofetch/neofetch-2.0.ebuild b/app-misc/neofetch/neofetch-2.0.ebuild
new file mode 100644
index 000000000000..70a6deb64b2b
--- /dev/null
+++ b/app-misc/neofetch/neofetch-2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Simple information system script"
+HOMEPAGE="https://github.com/dylanaraps/neofetch"
+SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="sys-apps/pciutils
+ X? (
+ x11-apps/xprop
+ x11-apps/xwininfo
+ x11-apps/xrandr
+ www-client/w3m[imlib]
+ media-libs/imlib2
+ media-gfx/imagemagick
+ )"
+
+pkg_postinst() {
+ ewarn "If you were updating this from 1.9.x, you may want to update your"
+ ewarn "configuration to the latest version because some old flags are"
+ ewarn "deprecated and may break neofetch. You can copy from"
+ ewarn "/usr/share/neofetch/config to your own config directory."
+}
diff --git a/app-misc/neofetch/neofetch-9999.ebuild b/app-misc/neofetch/neofetch-9999.ebuild
index e0bb14ebb08a..85203ceee7c7 100644
--- a/app-misc/neofetch/neofetch-9999.ebuild
+++ b/app-misc/neofetch/neofetch-9999.ebuild
@@ -6,14 +6,11 @@ inherit git-r3
DESCRIPTION="Simple information system script"
HOMEPAGE="https://github.com/dylanaraps/neofetch"
EGIT_REPO_URI="https://github.com/dylanaraps/neofetch.git"
-LICENSE="MIT"
+LICENSE="MIT-with-advertising"
SLOT="0"
IUSE="X"
-DEPEND="app-shells/bash:*
- sys-apps/pciutils"
-
-RDEPEND="${DEPEND}
+RDEPEND="sys-apps/pciutils
X? ( x11-apps/xprop
x11-apps/xwininfo
x11-apps/xrandr