summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-08-01 23:36:39 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-01 23:38:10 +0200
commit2ca53b27dfc551d66895c96bdfc0bad3cbacd596 (patch)
tree5adc8d138504f54e1a171bd319fa58f62e514750 /app-misc
parentnet-dns/knot: fix proxy maintainer name (diff)
downloadgentoo-2ca53b27dfc551d66895c96bdfc0bad3cbacd596.tar.gz
gentoo-2ca53b27dfc551d66895c96bdfc0bad3cbacd596.tar.bz2
gentoo-2ca53b27dfc551d66895c96bdfc0bad3cbacd596.zip
app-misc/fdupes: EAPI 6 bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fdupes/fdupes-1.6.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/fdupes/fdupes-1.6.1-r1.ebuild b/app-misc/fdupes/fdupes-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..b127dfcbd858
--- /dev/null
+++ b/app-misc/fdupes/fdupes-1.6.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Identify/delete duplicate files residing within specified directories"
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
+SRC_URI="https://github.com/adrianlopezroche/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+src_prepare() {
+ default
+ append-lfs-flags
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}