summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2018-06-17 14:49:17 +0300
committerMichał Górny <mgorny@gentoo.org>2018-06-17 14:29:53 +0200
commit68c065abe3e6b7218e840122997f7b3dd1739af3 (patch)
tree36c1891d29b28ef69521fbdc0721271fbd5e8478 /app-misc
parentapp-misc/pet: added slots to DEPEND (diff)
downloadgentoo-68c065abe3e6b7218e840122997f7b3dd1739af3.tar.gz
gentoo-68c065abe3e6b7218e840122997f7b3dd1739af3.tar.bz2
gentoo-68c065abe3e6b7218e840122997f7b3dd1739af3.zip
app-misc/pet: fix pkg_postinst (wrt #650096), use has_version
1. renamed pkg_postinstall to pkg_postinst (wrt #650096) 2. has_version used in conjunction with einfo Closes: https://bugs.gentoo.org/650096 Closes: https://github.com/gentoo/gentoo/pull/7413 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/pet/pet-0.3.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-misc/pet/pet-0.3.0.ebuild b/app-misc/pet/pet-0.3.0.ebuild
index f8536874f3a1..991478810dcf 100644
--- a/app-misc/pet/pet-0.3.0.ebuild
+++ b/app-misc/pet/pet-0.3.0.ebuild
@@ -48,10 +48,13 @@ src_install() {
if use zsh-completion ; then
insinto /usr/share/zsh/site-functions
- doins src/github.com/knqyf263/pet/misc/completions/zsh/_${PN}
+ doins src/github.com/knqyf263/pet/misc/completions/zsh/_pet
fi
}
-pkg_postinstall() {
- einfo "You should consider to install app-shells/peco to be able to use selector command"
+pkg_postinst() {
+ if ! has_version app-shells/peco ; then
+ einfo "You should consider to install app-shells/peco"
+ einfo "to be able to use selector command"
+ fi
}