summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-10-17 05:17:01 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-10-17 05:17:33 +0200
commit7bd7a74a20f600d8568dba3684b6df7611dea674 (patch)
treefab22e74dbdaebb1035eae3236d7c56215886df3 /app-misc
parentapp-misc/pfm: revbump: perl-module.eclass, EAPI=7, fix deps (diff)
downloadgentoo-7bd7a74a20f600d8568dba3684b6df7611dea674.tar.gz
gentoo-7bd7a74a20f600d8568dba3684b6df7611dea674.tar.bz2
gentoo-7bd7a74a20f600d8568dba3684b6df7611dea674.zip
app-misc/pip: revbump: EAPI 7, perl-module.eclass
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/pip/pip-1.2-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/pip/pip-1.2-r3.ebuild b/app-misc/pip/pip-1.2-r3.ebuild
new file mode 100644
index 000000000000..64323d92471d
--- /dev/null
+++ b/app-misc/pip/pip-1.2-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GENTOO_DEPEND_ON_PERL=noslotop
+inherit perl-module
+
+DESCRIPTION="Wrapper around programs that don't support stdin/stdout"
+HOMEPAGE="http://membled.com/work/apps/pip/"
+SRC_URI="http://membled.com/work/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+src_install() {
+ perl-module_src_install
+ mv "${ED}"/usr/bin/{pip,gpip} || die 'rename failed'
+}
+
+pkg_postinst() {
+ ewarn "To avoid collisions with dev-python/pip executable file of this package was renamed to 'gpip'"
+}