summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2016-07-23 09:11:43 +0100
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2016-07-23 17:18:56 +0100
commit8f079e5a55493424277efe239ba1aa7d7dbc8c35 (patch)
treeecb1d1000a79227d2a6fda9901b2de7cbfa42329 /app-misc
parentapp-admin/sudo: Bump to version 1.8.17_p1 (diff)
downloadgentoo-8f079e5a55493424277efe239ba1aa7d7dbc8c35.tar.gz
gentoo-8f079e5a55493424277efe239ba1aa7d7dbc8c35.tar.bz2
gentoo-8f079e5a55493424277efe239ba1aa7d7dbc8c35.zip
app-misc/tek: Add new package
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tek/Manifest1
-rw-r--r--app-misc/tek/metadata.xml8
-rw-r--r--app-misc/tek/tek-1.3.0.ebuild44
3 files changed, 53 insertions, 0 deletions
diff --git a/app-misc/tek/Manifest b/app-misc/tek/Manifest
new file mode 100644
index 000000000000..24f7a37c8ff8
--- /dev/null
+++ b/app-misc/tek/Manifest
@@ -0,0 +1 @@
+DIST tek-1.3.0.tar.gz 99399 SHA256 730e43749bf83fe1f717a64754262fe0577d25b3b47896838d4936fd8f76ffe6 SHA512 20e3e704db71a7c0fb7a7791c8ebbdb348d370b06bea39f2ee77cae72ac4b71873884c6ec58712c9bf85d7d0785310f33189ce977a77b970951e39c8803d28fd WHIRLPOOL 2736f63121b2a743234ddd972a88562f1e8094c45fc6aec79dbda1c5d2a4c8df776db6f6f997c88afd6155e5fdaffa44859b6ba987a987bb09c36556764b4e5f
diff --git a/app-misc/tek/metadata.xml b/app-misc/tek/metadata.xml
new file mode 100644
index 000000000000..674f5ad944f3
--- /dev/null
+++ b/app-misc/tek/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/tek/tek-1.3.0.ebuild b/app-misc/tek/tek-1.3.0.ebuild
new file mode 100644
index 000000000000..692a5844873b
--- /dev/null
+++ b/app-misc/tek/tek-1.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+WX_GTK_VER=3.0
+
+inherit udev wxwidgets
+
+DESCRIPTION="GUI tool for upgrading the firmware of a Truly Ergonomic Keyboard"
+HOMEPAGE="http://trulyergonomic.com/ https://github.com/m-ou-se/tek"
+SRC_URI="https://github.com/m-ou-se/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="all-rights-reserved GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}=[X]
+ virtual/udev"
+DEPEND="${RDEPEND}
+ app-editors/vim-core"
+
+src_prepare() {
+ default
+ setup-wxwidgets
+ sed -r \
+ -e '/LIN_STRIP/d' \
+ -e 's/LIN_CXX/CXX/g' \
+ -e 's/CXX=/CXX\?=/' \
+ -e 's/CXXFLAGS=(.*)/CXXFLAGS:=\1 $(CXXFLAGS)/' \
+ -i "${S}"/Makefile || die
+}
+
+src_install() {
+ newbin tek.lin tek
+ udev_newrules linux-udev-rules 40-tek.rules
+ einstalldocs
+}
+
+pkg_postinst() {
+ udev_reload
+}