summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-08-01 23:05:24 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-01 23:05:24 +0200
commitb0605337893c81f97a4f94dde98bd27e5ae2b010 (patch)
treee564ae54651668c7c762d9d5f0c83c1e24b05177 /app-misc
parentapp-text/agrep: clean up old. (diff)
downloadgentoo-b0605337893c81f97a4f94dde98bd27e5ae2b010.tar.gz
gentoo-b0605337893c81f97a4f94dde98bd27e5ae2b010.tar.bz2
gentoo-b0605337893c81f97a4f94dde98bd27e5ae2b010.zip
app-misc/boxes: EAPI 6 bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/boxes/boxes-1.1.2-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/boxes/boxes-1.1.2-r3.ebuild b/app-misc/boxes/boxes-1.1.2-r3.ebuild
new file mode 100644
index 000000000000..737c507427ac
--- /dev/null
+++ b/app-misc/boxes/boxes-1.1.2-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Draw any kind of boxes around your text"
+HOMEPAGE="http://boxes.thomasjensen.com/ https://github.com/ascii-boxes/boxes"
+SRC_URI="https://github.com/ascii-boxes/boxes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ sys-devel/flex
+ sys-devel/bison"
+
+src_prepare() {
+ default
+ append-cflags -Iregexp -I. -ansi -std=c99
+ append-ldflags -Lregexp
+ sed \
+ -e 's:STRIP=true:STRIP=false:g' \
+ -i src/Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin src/boxes
+ doman doc/boxes.1
+ insinto /usr/share
+ newins boxes-config boxes
+ einstalldocs
+}