summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-07-03 11:28:16 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-07-03 11:29:09 +0200
commitbda5ac1e6b5dc149f7d0491b8089e1cb8fc80e82 (patch)
treec216868046cb97cbda6cd5bf6b44b86bcbc2c31b /app-misc
parentapp-misc/abook: improve long description. (diff)
downloadgentoo-bda5ac1e6b5dc149f7d0491b8089e1cb8fc80e82.tar.gz
gentoo-bda5ac1e6b5dc149f7d0491b8089e1cb8fc80e82.tar.bz2
gentoo-bda5ac1e6b5dc149f7d0491b8089e1cb8fc80e82.zip
app-misc/abook: EAPI 6 bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/abook/abook-0.6.1-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/abook/abook-0.6.1-r1.ebuild b/app-misc/abook/abook-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..4d1dccd13b8f
--- /dev/null
+++ b/app-misc/abook/abook-0.6.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${P/_/}"
+DESCRIPTION="Abook is a text-based addressbook program designed to use with mutt mail client"
+HOMEPAGE="http://abook.sourceforge.net/"
+SRC_URI="http://abook.sourceforge.net/devel/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ sys-libs/ncurses
+ sys-libs/readline
+ dev-libs/libvformat
+ nls? ( virtual/libintl )"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( BUGS ChangeLog FAQ README TODO sample.abookrc )
+
+src_prepare() {
+ default
+
+ # TODO: do the right thing and find out whats wrong with Makefile.in
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-curses \
+ --with-readline \
+ --enable-vformat \
+ $(use_enable nls)
+}
+
+src_compile() {
+ # bug 570428
+ emake CFLAGS="${CFLAGS} -std=gnu89"
+}
+
+src_install() {
+ default
+}