summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-25 13:07:27 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-25 13:08:04 +0100
commitcf577da0714eb531ae6036fa5fad78eeb2564684 (patch)
tree4fdf5a1b0bd2602cbed1f7c6e4a1f8091bc5883c /app-misc
parentapp-misc/birthday: Fix test failures (diff)
downloadgentoo-cf577da0714eb531ae6036fa5fad78eeb2564684.tar.gz
gentoo-cf577da0714eb531ae6036fa5fad78eeb2564684.tar.bz2
gentoo-cf577da0714eb531ae6036fa5fad78eeb2564684.zip
app-misc/birthday: Bump EAPI
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/birthday/birthday-1.6.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/birthday/birthday-1.6.2-r1.ebuild b/app-misc/birthday/birthday-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..dcfe624184f8
--- /dev/null
+++ b/app-misc/birthday/birthday-1.6.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays a list of events happening in the near future"
+HOMEPAGE="http://sourceforge.net/projects/birthday/"
+SRC_URI="mirror://sourceforge/birthday/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ # Don't strip, install in correct share dir and respect CFLAGS
+ sed \
+ -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
+ -i Makefile || die
+ sed \
+ -e 's:grep -v:grep --binary-files=text -v:g' \
+ -i runtest.sh || die
+
+ default
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}