summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-08-03 22:08:30 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-03 22:11:19 +0200
commitcfd560ee7b35cfd78231d9da747c7b733c4bbf2d (patch)
tree4c6275170424e4432e3c9e68887acf817e96cc63 /app-misc
parentapp-misc/vlock: EAPI 6 bump. (diff)
downloadgentoo-cfd560ee7b35cfd78231d9da747c7b733c4bbf2d.tar.gz
gentoo-cfd560ee7b35cfd78231d9da747c7b733c4bbf2d.tar.bz2
gentoo-cfd560ee7b35cfd78231d9da747c7b733c4bbf2d.zip
app-misc/tmux: add a dependency on app-vim/vim-tmux.
Turning on the vim-syntax USE flag will now install the app-vim/vim-tmux plugin instead of just one single file. This plugin can be found at https://github.com/tmux-plugins/vim-tmux. Gentoo-Bug: https://bugs.gentoo.org/603526 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tmux/tmux-2.5-r2.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/app-misc/tmux/tmux-2.5-r2.ebuild b/app-misc/tmux/tmux-2.5-r2.ebuild
new file mode 100644
index 000000000000..092a05aeac5f
--- /dev/null
+++ b/app-misc/tmux/tmux-2.5-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic versionator
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV/_*}/${P/_/-}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug selinux utempter vim-syntax kernel_FreeBSD kernel_linux"
+
+CDEPEND="
+ dev-libs/libevent:0=
+ sys-libs/ncurses:0=
+ utempter? (
+ kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
+ )"
+
+DEPEND="
+ ${CDEPEND}
+ virtual/pkgconfig"
+
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-screen )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ app-vim/vim-tmux
+ )"
+
+DOCS=( CHANGES FAQ README TODO example_tmux.conf )
+
+PATCHES=(
+ # usptream fixes (can be removed with next version bump)
+ "${FILESDIR}/${PN}-2.4-flags.patch"
+)
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ # bug 438558
+ # 1.7 segfaults when entering copy mode if compiled with -Os
+ replace-flags -Os -O2
+
+ # regenerate aclocal.m4 to support earlier automake versions
+ rm -v aclocal.m4 || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc
+ $(use_enable debug)
+ $(use_enable utempter)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ if ! version_is_at_least 1.9a ${REPLACING_VERSIONS:-1.9a}; then
+ echo
+ ewarn "Some configuration options changed in this release."
+ ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
+ ewarn
+ ewarn "WARNING: After updating to ${P} you will _not_ be able to connect to any"
+ ewarn "older, running tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to access them."
+ echo
+ fi
+}