summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-10 00:38:04 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-10 00:58:17 +0200
commitf47a7cfd27c96693cb4ee9f1919a058c5f603248 (patch)
tree1e5692e8eaffd8b305c20acfb566fee9d25844d5 /app-misc
parentapp-arch/file-roller: add CPE to metadata (diff)
downloadgentoo-f47a7cfd27c96693cb4ee9f1919a058c5f603248.tar.gz
gentoo-f47a7cfd27c96693cb4ee9f1919a058c5f603248.tar.bz2
gentoo-f47a7cfd27c96693cb4ee9f1919a058c5f603248.zip
app-misc/gnote: version bump 3.22.1 → 3.24.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gnote/Manifest1
-rw-r--r--app-misc/gnote/gnote-3.24.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index e1bc66fbd023..90520a393ab3 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1 +1,2 @@
DIST gnote-3.22.1.tar.xz 3309984 SHA256 fa9434c2ba11bea73bd63436e5fd76949aca4f66dfd902295629c66ef27cd5eb SHA512 0bbf89b39699294fe5a373decf10bcd7f3a86a20c49b9d82699fb758c7cd27b6939764236a1a7ffe21964a2ae196780d0861123776b1568344935e0b649e2f5f WHIRLPOOL b36307a24800078843a1cf6217aa7f2a88f2c2f2cc6707ac0b93a7c735e8e820b3ed3f07132647cb47273286771006150a4fe05c425f63554e4da0dee0d100ae
+DIST gnote-3.24.0.tar.xz 3307940 SHA256 62e38c19ce7dfcd895729adabd72f654f31e03f28dbf4cbca68279e745c79cd4 SHA512 640f24d1829a546e53eb2d269f965daafa651e141566fd2f7a4572245b309c06259f548fa38c86c55954f2d0f8f98c48b7da2ed982864ae6ffbcac4b5d64aecb WHIRLPOOL b866cde708f9950fe4b4a9af4e97bcc06336e61cfcbf649162323162daf7ef7a1c536ffec9460dc580d54e3cc3a03606967a6ff5aad79b5b847e20c4234ab707
diff --git a/app-misc/gnote/gnote-3.24.0.ebuild b/app-misc/gnote/gnote-3.24.0.ebuild
new file mode 100644
index 000000000000..b0b68f6acf71
--- /dev/null
+++ b/app-misc/gnote/gnote-3.24.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Automagic:
+# glib-2.32 dep
+# >=dev-libs/unittest++-1.5.1 (but not detected due to missing .pc)
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gtkspell-3.0:3
+ >=dev-cpp/glibmm-2.32:2
+ >=dev-cpp/gtkmm-3.18:3.0
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.20:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}