summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-01-17 23:51:58 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-17 23:52:13 +0100
commitf7999690404f400eec1a2da59586c4d0a3b61f9a (patch)
tree0bcccb29bcdf4adf1682a5bb1d86a71b67e3db87 /app-misc
parentapp-misc/cmatrix: clean up old.. (diff)
downloadgentoo-f7999690404f400eec1a2da59586c4d0a3b61f9a.tar.gz
gentoo-f7999690404f400eec1a2da59586c4d0a3b61f9a.tar.bz2
gentoo-f7999690404f400eec1a2da59586c4d0a3b61f9a.zip
app-misc/lsx: EAPI 6 bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/lsx/lsx-0.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/lsx/lsx-0.1-r1.ebuild b/app-misc/lsx/lsx-0.1-r1.ebuild
new file mode 100644
index 000000000000..aea95629b8b9
--- /dev/null
+++ b/app-misc/lsx/lsx-0.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="list executables"
+HOMEPAGE="http://tools.suckless.org/lsx"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+
+ # collision with net-dialup/lrzsz
+ mv "${D}/usr/bin/${PN}" "${D}/usr/bin/${PN}-suckless" || die
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Run ${PN} with ${PN}-suckless"
+}