summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild')
-rw-r--r--app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild b/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild
new file mode 100644
index 000000000000..3f7ff95aaf65
--- /dev/null
+++ b/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-r1
+
+DESCRIPTION="Gnome frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-mobilephone/anyremote-6.5[bluetooth=]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/ || die
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ "${T}"/gettextize -f --no-changelog > /dev/null || die
+
+ # remove deprecated entry
+ sed -e "/Encoding=UTF-8/d" \
+ -i ganyremote.desktop || die "fixing .desktop file failed"
+
+ # fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am || die
+ eautoreconf
+
+ # disable bluetooth check to avoid errors
+ if ! use bluetooth ; then
+ sed -e "s/usepybluez = True/usepybluez = False/" -i ganyremote || die
+ fi
+}
+
+src_install() {
+ default
+
+ python_replicate_script "${D}"/usr/bin/ganyremote
+}