summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/kannel-sqlbox/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/kannel-sqlbox/files')
-rw-r--r--app-mobilephone/kannel-sqlbox/files/kannel-sqlbox-0.7.2-configure.patch30
-rw-r--r--app-mobilephone/kannel-sqlbox/files/kannel-sqlbox-0.7.2-sqlinit-hfiles.patch84
-rw-r--r--app-mobilephone/kannel-sqlbox/files/kannel-sqlbox.initd34
3 files changed, 148 insertions, 0 deletions
diff --git a/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox-0.7.2-configure.patch b/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox-0.7.2-configure.patch
new file mode 100644
index 000000000000..2b0b5f9e6218
--- /dev/null
+++ b/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox-0.7.2-configure.patch
@@ -0,0 +1,30 @@
+diff -Nru sqlbox-0.7.2.orig/configure.in sqlbox-0.7.2/configure.in
+--- sqlbox-0.7.2.orig/configure.in 2009-05-19 17:08:35.000000000 +0200
++++ sqlbox-0.7.2/configure.in 2009-09-23 00:22:05.000000000 +0200
+@@ -207,7 +207,7 @@
+ then
+ AC_CHECK_PROG(JADE, openjade, openjade, no)
+ else
+- JADE = $OLDJADE
++ JADE=$OLDJADE
+ fi
+ AC_CHECK_PROG(JADETEX, jadetex, jadetex, no)
+ AC_CHECK_PROG(PDFJADETEX, pdfjadetex, pdfjadetex, no)
+@@ -402,7 +402,7 @@
+ AC_MSG_RESULT($loc)
+ AC_CHECK_FILE("$loc/include/kannel/gw-config.h",
+ [CFLAGS="$CFLAGS -I$loc/include/kannel -I$loc/include/kannel";
+- LDFLAGS="$LDFLAGS -L$loc/lib/kannel -lwap -lgwlib";
++ LIBS="$LIBS -L$loc/lib/kannel -lwap -lgwlib";
+ found=1
+ ])
+ fi
+@@ -417,7 +417,7 @@
+ AC_MSG_RESULT([$gw_version])
+ AC_MSG_CHECKING([Kannel libs])
+ if ! $GW_CONFIG --libs &>/dev/null ; then
+- LDFLAGS="$LDFLAGS `$GW_CONFIG --libs`"
++ LIBS="$LIBS `$GW_CONFIG --libs`"
+ gw_libdir=`$GW_CONFIG --libs`
+ AC_MSG_RESULT([$gw_libdir])
+ fi
diff --git a/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox-0.7.2-sqlinit-hfiles.patch b/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox-0.7.2-sqlinit-hfiles.patch
new file mode 100644
index 000000000000..0a3fb9136709
--- /dev/null
+++ b/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox-0.7.2-sqlinit-hfiles.patch
@@ -0,0 +1,84 @@
+diff -Naur sqlbox-0.7.2/gw/sqlbox_mssql.h sqlbox-0.7.2.new/gw/sqlbox_mssql.h
+--- sqlbox-0.7.2/gw/sqlbox_mssql.h 2009-05-19 11:08:35.000000000 -0400
++++ sqlbox-0.7.2.new/gw/sqlbox_mssql.h 2009-09-16 11:23:03.000000000 -0400
+@@ -46,7 +46,7 @@
+ void sql_save_msg(Msg *msg, Octstr *momt /*, Octstr smsbox_id */);
+ Msg *mssql_fetch_msg();
+ void sql_shutdown();
+-struct server_type *sql_init_mssql(Cfg *cfg);
++struct server_type *sqlbox_init_mssql(Cfg *cfg);
+ #ifndef sqlbox_mssql_c
+ extern
+ #endif
+diff -Naur sqlbox-0.7.2/gw/sqlbox_mysql.h sqlbox-0.7.2.new/gw/sqlbox_mysql.h
+--- sqlbox-0.7.2/gw/sqlbox_mysql.h 2009-05-19 11:08:35.000000000 -0400
++++ sqlbox-0.7.2.new/gw/sqlbox_mysql.h 2009-09-16 11:23:03.000000000 -0400
+@@ -48,7 +48,7 @@
+ void sql_save_msg(Msg *msg, Octstr *momt);
+ Msg *mysql_fetch_msg();
+ void sql_shutdown();
+-struct server_type *sql_init_mysql(Cfg *cfg);
++struct server_type *sqlbox_init_mysql(Cfg *cfg);
+ #ifndef sqlbox_mysql_c
+ extern
+ #endif
+diff -Naur sqlbox-0.7.2/gw/sqlbox_oracle.h sqlbox-0.7.2.new/gw/sqlbox_oracle.h
+--- sqlbox-0.7.2/gw/sqlbox_oracle.h 2009-05-19 11:08:35.000000000 -0400
++++ sqlbox-0.7.2.new/gw/sqlbox_oracle.h 2009-09-16 11:23:03.000000000 -0400
+@@ -52,7 +52,7 @@
+ void sql_save_msg(Msg *msg, Octstr *momt /*, Octstr smsbox_id */);
+ Msg *oracle_fetch_msg();
+ void sql_shutdown();
+-struct server_type *sql_init_oracle(Cfg *cfg);
++struct server_type *sqlbox_init_oracle(Cfg *cfg);
+ #ifndef sqlbox_oracle_c
+ extern
+ #endif
+diff -Naur sqlbox-0.7.2/gw/sqlbox_pgsql.h sqlbox-0.7.2.new/gw/sqlbox_pgsql.h
+--- sqlbox-0.7.2/gw/sqlbox_pgsql.h 2009-05-19 11:08:35.000000000 -0400
++++ sqlbox-0.7.2.new/gw/sqlbox_pgsql.h 2009-09-16 11:23:03.000000000 -0400
+@@ -44,7 +44,7 @@
+ void sql_save_msg(Msg *msg, Octstr *momt /*, Octstr smsbox_id */);
+ Msg *pgsql_fetch_msg();
+ void sql_shutdown();
+-struct server_type *sql_init_pgsql(Cfg *cfg);
++struct server_type *sqlbox_init_pgsql(Cfg *cfg);
+ void sqlbox_configure_pgsql(Cfg* cfg);
+ #ifndef sqlbox_pgsql_c
+ extern
+diff -Naur sqlbox-0.7.2/gw/sqlbox_sdb.h sqlbox-0.7.2.new/gw/sqlbox_sdb.h
+--- sqlbox-0.7.2/gw/sqlbox_sdb.h 2009-05-19 11:08:35.000000000 -0400
++++ sqlbox-0.7.2.new/gw/sqlbox_sdb.h 2009-09-16 11:23:03.000000000 -0400
+@@ -21,7 +21,7 @@
+ void sql_save_msg(Msg *msg, Octstr *momt );
+ Msg *sdb_fetch_msg();
+ void sql_shutdown();
+-struct server_type *sql_init_sdb(Cfg *cfg);
++struct server_type *sqlbox_init_sdb(Cfg *cfg);
+ #ifndef sqlbox_sdb_c
+ extern
+ #endif
+diff -Naur sqlbox-0.7.2/gw/sqlbox_sqlite3.h sqlbox-0.7.2.new/gw/sqlbox_sqlite3.h
+--- sqlbox-0.7.2/gw/sqlbox_sqlite3.h 2009-05-19 11:08:35.000000000 -0400
++++ sqlbox-0.7.2.new/gw/sqlbox_sqlite3.h 2009-09-16 11:23:03.000000000 -0400
+@@ -41,7 +41,7 @@
+ void sql_save_msg(Msg *msg, Octstr *momt );
+ Msg *sqlite3_fetch_msg();
+ void sql_shutdown();
+-struct server_type *sql_init_sqlite3(Cfg *cfg);
++struct server_type *sqlbox_init_sqlite3(Cfg *cfg);
+ #ifndef sqlbox_sqlite3_c
+ extern
+ #endif
+diff -Naur sqlbox-0.7.2/gw/sqlbox_sqlite.h sqlbox-0.7.2.new/gw/sqlbox_sqlite.h
+--- sqlbox-0.7.2/gw/sqlbox_sqlite.h 2009-05-19 11:08:35.000000000 -0400
++++ sqlbox-0.7.2.new/gw/sqlbox_sqlite.h 2009-09-16 11:23:03.000000000 -0400
+@@ -41,7 +41,7 @@
+ void sql_save_msg(Msg *msg, Octstr *momt );
+ Msg *sqlite_fetch_msg();
+ void sql_shutdown();
+-struct server_type *sql_init_sqlite(Cfg *cfg);
++struct server_type *sqlbox_init_sqlite(Cfg *cfg);
+ #ifndef sqlbox_sqlite_c
+ extern
+ #endif \ No newline at end of file
diff --git a/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox.initd b/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox.initd
new file mode 100644
index 000000000000..d746cd5db29e
--- /dev/null
+++ b/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox.initd
@@ -0,0 +1,34 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+KANNEL_SERVICE=${SVCNAME#*-}
+
+depend() {
+ need kannel-bearerbox
+ before kannel-smsbox
+}
+
+checkconfig() {
+ if [ ! -f /etc/kannel/kannel.conf ] ; then
+ eerror "/etc/kannel/kannel.conf file doesn't exists!"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting kannel ${KANNEL_SERVICE}"
+ start-stop-daemon --start --quiet --exec /usr/sbin/${KANNEL_SERVICE} -- \
+ --daemonize --user kannel --logfile /var/log/kannel/${KANNEL_SERVICE}.log \
+ --pid-file /var/run/kannel/${KANNEL_SERVICE}.pid /etc/kannel/sqlbox.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping kannel ${KANNEL_SERVICE}"
+ start-stop-daemon --stop --verbose --pidfile /var/run/kannel/${KANNEL_SERVICE}.pid
+ eend $?
+}