summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/obex-data-server
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/obex-data-server')
-rw-r--r--app-mobilephone/obex-data-server/Manifest1
-rw-r--r--app-mobilephone/obex-data-server/metadata.xml13
-rw-r--r--app-mobilephone/obex-data-server/obex-data-server-0.4.6.ebuild40
3 files changed, 54 insertions, 0 deletions
diff --git a/app-mobilephone/obex-data-server/Manifest b/app-mobilephone/obex-data-server/Manifest
new file mode 100644
index 000000000000..c3a2b5d2332a
--- /dev/null
+++ b/app-mobilephone/obex-data-server/Manifest
@@ -0,0 +1 @@
+DIST obex-data-server-0.4.6.tar.gz 199188 SHA256 b399465ddbd6d0217abedd9411d9d74a820effa0a6a142adc448268d3920094f SHA512 5f924377fa45fec22a15d74fa45bf6ae98f56a9f8c98142cce6123e4ca6dcca042a636469b491f4103e230e270ad1af18dc38274b661795cac4beb4f7b798d5b WHIRLPOOL 85ef3de72124c25b5b486e2fefdf453ddc318e5f8520ada7c772d7e7a6939b954a6a66cf962ed3aa257d5212ab047f556aced5cbfa94a1a360e897a6da6fa90a
diff --git a/app-mobilephone/obex-data-server/metadata.xml b/app-mobilephone/obex-data-server/metadata.xml
new file mode 100644
index 000000000000..0bb29177488f
--- /dev/null
+++ b/app-mobilephone/obex-data-server/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription>
+ A DBus service providing easy to use API for using OBEX protocol
+ (both client and server wise). Current implementation supports OPP
+ (Object Push Profile) and FTP (File Transfer Profile). This means
+ that you can have FTP server running on your Bluetooth adapter with
+ several lines of python, you can also do all client operations without
+ having to use openobex directly or knowing any of low-level OBEX stuff.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-mobilephone/obex-data-server/obex-data-server-0.4.6.ebuild b/app-mobilephone/obex-data-server/obex-data-server-0.4.6.ebuild
new file mode 100644
index 000000000000..642dc5aee6b8
--- /dev/null
+++ b/app-mobilephone/obex-data-server/obex-data-server-0.4.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="A DBus service providing easy to use API for using OBEX"
+HOMEPAGE="http://tadas.dailyda.com/blog/category/obex-data-server/"
+SRC_URI="http://tadas.dailyda.com/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 x86"
+
+IUSE="debug gtk imagemagick usb"
+
+RDEPEND="dev-libs/glib:2
+ >=dev-libs/dbus-glib-0.7
+ sys-apps/dbus
+ >=net-wireless/bluez-4.31
+ <dev-libs/openobex-1.7.1
+ imagemagick? ( !gtk? ( || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] ) ) )
+ gtk? ( x11-libs/gtk+:2 )
+ usb? ( virtual/libusb:0 )
+ !app-mobilephone/obexd[server]"
+
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_configure() {
+ local bip="no"
+ use imagemagick && bip="magick"
+ use gtk && bip="gdk-pixbuf"
+ econf \
+ --enable-bip=${bip} \
+ $(use_enable usb) \
+ --disable-system-config \
+ $(use_enable debug) \
+ --disable-silent-rules
+}