summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2016-02-02 21:37:20 +0100
committerSebastian Pipping <sping@gentoo.org>2016-02-02 21:50:17 +0100
commit33ba954a2247e36de35acae4f96da4dceb0bceed (patch)
tree5f330016cdfe511486de017e8cd77f3fa80ca355 /app-mobilephone/wammu
parentdev-db/firebird: Add name and description to metadata.xml (diff)
downloadgentoo-33ba954a2247e36de35acae4f96da4dceb0bceed.tar.gz
gentoo-33ba954a2247e36de35acae4f96da4dceb0bceed.tar.bz2
gentoo-33ba954a2247e36de35acae4f96da4dceb0bceed.zip
app-mobilephone/wammu: 0.40
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-mobilephone/wammu')
-rw-r--r--app-mobilephone/wammu/Manifest1
-rw-r--r--app-mobilephone/wammu/wammu-0.40.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-mobilephone/wammu/Manifest b/app-mobilephone/wammu/Manifest
index fd46156e79cd..c110d24d1d3f 100644
--- a/app-mobilephone/wammu/Manifest
+++ b/app-mobilephone/wammu/Manifest
@@ -1,2 +1,3 @@
DIST wammu-0.35.tar.bz2 572550 SHA256 fba70bb0a067f20bb5da5f16061e6cc70a49761ca11f49a897af678271666d7a SHA512 c9c24a170d0a1b1507799f77719d544a04b0c894172e0158efc782f25ec894eaa65e2a89b53db431a96b5f88ccadf4dddc5025ba84ac09d54aa5d37b2e658461 WHIRLPOOL 8b6b4edc77c46f20b449077f198d4e51ad81edd6846c69a4945ebf207ae01431a3cb31541e8f07c1b8c90fa37c2034acec771e5d563e0bf756aba1f175f93a9f
DIST wammu-0.36.tar.bz2 581781 SHA256 8107d69438adc5c9c24565f455cac31ecd5b9ef754f26a6b5ebab03b49131696 SHA512 08caaeb7ade5877b441baad2f3f1f653ed1c25c3fab213e093213525fe326f09ee8ccda4db834f82b00a9d7e9b2cb235da7be7f328c091b6067543d9cdbfb14c WHIRLPOOL 6b4b8aff5363bbf39bb9b67765c9373600642592bc910d3b4d83d09d88d5b5ad4945d4f27f2c75c383ae55f66cc71e21756fcd93e1adee3dfeeef5a766f449c8
+DIST wammu-0.40.tar.bz2 687062 SHA256 cffd4fc6cc7b9433b3f589d51671a5ac5e188abbf676ebe0ce94011933fdb2ff SHA512 2ed5d5cdd63b3731808c5fa8cc36caf394c4ccf714eb4ef39a25f1e7967d8ccf8b69db5aeff37ff0d1bbf7cefec51fe070a5f0b90d0cb8271f1a3d243eaf06fd WHIRLPOOL b05dac88593c5ae3c01f63984824690991a347e4efff2bf3595b1088d9903843e018690845391ab48f62ab7d17f11d0b3a801103a1c408822b1c9afdd88f7150
diff --git a/app-mobilephone/wammu/wammu-0.40.ebuild b/app-mobilephone/wammu/wammu-0.40.ebuild
new file mode 100644
index 000000000000..6707609bb58b
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.40.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Front-end for gammu to access mobile phones easily"
+HOMEPAGE="http://www.wammu.eu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth gnome"
+
+RDEPEND="|| ( ( >=app-mobilephone/gammu-1.36 dev-python/python-gammu )
+ >=app-mobilephone/gammu-1.25.0[python] )
+ >=dev-python/wxpython-2.8:*[${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}]
+ gnome? ( net-wireless/gnome-bluetooth )
+ )"
+DEPEND="${RDEPEND}"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af ar bg bn ca cs da de el en_GB es et fi fr gl he hu id it ko nl pl pt_BR ro ru sk sv sw tr uk zh_CN zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+# Required to source locale content out of the box
+DISTUTILS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ local lang support_linguas=no
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if use linguas_${lang} ; then
+ support_linguas=yes
+ break
+ fi
+ done
+ # install all languages when all selected LINGUAS aren't supported
+ if [ "${support_linguas}" = "yes" ]; then
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -r locale/${lang} || die
+ fi
+ done
+ fi
+
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils-r1_src_compile
+}
+
+src_install() {
+ SKIPWXCHECK=yes distutils-r1_src_install
+}